Closed Bug 1651770 Opened 3 months ago Closed 2 months ago

ThreadSanitizer: lock-order-inversion in [@ mozilla::camera::CamerasChild::EnsureInitialized]

Categories

(Core :: WebRTC: Audio/Video, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: tsmith, Assigned: bwc)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

The attached crash information was detected by ThreadSanitizer by opening https://webrtc.github.io/test-pages/src/audio-and-video/ on mozilla-central 20200708-34fb169ef962. I think this maybe a false positive because everything is happening on the same thread. If so I will add a suppression.

General information about TSan reports

Why fix races?

Data races are undefined behavior and can cause crashes as well as correctness issues. Compiler optimizations can cause racy code to have unpredictable and hard-to-reproduce behavior.

Rating

If you think this race can cause crashes or correctness issues, it would be great to rate the bug appropriately as P1/P2 and/or indicating this in the bug. This makes it a lot easier for us to assess the actual impact that these reports make and if they are helpful to you.

False Positives / Benign Races

Typically, races reported by TSan are not false positives [1], but it is possible that the race is benign. Even in this case it would be nice to come up with a fix if it is easily doable and does not regress performance. Every race that we cannot fix will have to remain on the suppression list and slows down the overall TSan performance. Also note that seemingly benign races can possibly be harmful (also depending on the compiler, optimizations and the architecture) [2][3].

[1] One major exception is the involvement of uninstrumented code from third-party libraries.
[2] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[3] How to miscompile programs with "benign" data races: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf

Suppressing unfixable races

If the bug cannot be fixed, then a runtime suppression needs to be added in mozglue/build/TsanOptions.cpp. The suppressions match on the full stack, so it should be picked such that it is unique to this particular race. The bug number of this bug should also be included so we have some documentation on why this suppression was added.

Seeing this on local builds also.

:jib, is this something you have time to look into?

Severity: -- → S3
Flags: needinfo?(jib)
Priority: -- → P2

I think this maybe a false positive because everything is happening on the same thread. If so I will add a suppression.

I agree. This seems intentional. "Cycle in lock order graph: M17260 => M17259 => M17260"

"Mutex M17260 acquired here while holding mutex M17259 in thread T28:"

class LockAndDispatch {
 public:
  LockAndDispatch(CamerasChild* aCamerasChild, const char* aRequestingFunc,
                  nsIRunnable* aRunnable, const T& aFailureValue,
                  const T& aSuccessValue)
      : mCamerasChild(aCamerasChild),
        mRequestingFunc(aRequestingFunc),
        mRunnable(aRunnable),
        mReplyLock(aCamerasChild->mReplyMonitor),   // M17260
        mRequestLock(aCamerasChild->mRequestMutex), // M17259
        mSuccess(true),
        mFailureValue(aFailureValue),
        mSuccessValue(aSuccessValue) {
#7> Dispatch();
  }

  void Dispatch() {
#6> if (!mCamerasChild->DispatchToParent(mRunnable, mReplyLock)) { // Wait()s on M17260
      LOG(("Cameras dispatch for IPC failed in %s", mRequestingFunc));
      mSuccess = false;
    }
  }
Flags: needinfo?(jib)

Yeah, I guess we should suppress this.

Assignee: nobody → docfaraday
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3ec1fb624570
Suppress lock-order-inversion warning in CamerasChild. r=decoder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.