Closed Bug 1651867 Opened 2 months ago Closed 2 months ago

Permafailing tier 2 mozlint E: fixture 'root' not found

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect

Tracking

(firefox-esr68 unaffected, firefox-esr78 unaffected, firefox78 unaffected, firefox79 unaffected, firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- fixed

People

(Reporter: nataliaCs, Assigned: tomprince)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=e2a60cd0189cb950d96a1cc35ee1523a1bb7dbd4&searchStr=mozlint&group_state=expanded&selectedTaskRun=PWT5faWmTBKAqulWHRIDBA.0

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=309220511&repo=autoland

[task 2020-07-09T23:48:58.449Z] 0:34.58 _______ ERROR at setup of test_lint_excluded_file_with_no_filter[flake8] _______
[task 2020-07-09T23:48:58.449Z] 0:34.58 file /builds/worker/checkouts/gecko/tools/lint/test/test_flake8.py, line 97
[task 2020-07-09T23:48:58.449Z] 0:34.58 def test_lint_excluded_file_with_no_filter(lint, paths, config):
[task 2020-07-09T23:48:58.449Z] 0:34.58 file /builds/worker/checkouts/gecko/tools/lint/test/conftest.py, line 68
[task 2020-07-09T23:48:58.449Z] 0:34.58 @pytest.fixture(scope="module")
[task 2020-07-09T23:48:58.449Z] 0:34.58 def paths(root):
[task 2020-07-09T23:48:58.449Z] 0:34.58 E fixture 'root' not found
[task 2020-07-09T23:48:58.449Z] 0:34.58 > available fixtures: cache, capfd, capfdbinary, caplog, capsys, capsysbinary, create_temp_file, doctest_namespace, lint, monkeypatch, paths, pytestconfig, record_property, record_xml_attribute, record_xml_property, recwarn, run_setup, tmpdir, tmpdir_factory
[task 2020-07-09T23:48:58.449Z] 0:34.58 > use 'pytest --fixtures [testpath]' for help on them.
[task 2020-07-09T23:48:58.449Z] 0:34.58
[task 2020-07-09T23:48:58.449Z] 0:34.58 /builds/worker/checkouts/gecko/tools/lint/test/conftest.py:68
[task 2020-07-09T23:48:58.449Z] 0:34.58 __________ ERROR at setup of test_lint_uses_custom_extensions[flake8] __________
[task 2020-07-09T23:48:58.449Z] 0:34.58 file /builds/worker/checkouts/gecko/tools/lint/test/test_flake8.py, line 103
[task 2020-07-09T23:48:58.449Z] 0:34.58 def test_lint_uses_custom_extensions(lint, paths):
[task 2020-07-09T23:48:58.449Z] 0:34.58 file /builds/worker/checkouts/gecko/tools/lint/test/conftest.py, line 68
[task 2020-07-09T23:48:58.449Z] 0:34.58 @pytest.fixture(scope="module")
[task 2020-07-09T23:48:58.450Z] 0:34.58 def paths(root):
[task 2020-07-09T23:48:58.450Z] 0:34.58 E fixture 'root' not found
[task 2020-07-09T23:48:58.450Z] 0:34.58 > available fixtures: cache, capfd, capfdbinary, caplog, capsys, capsysbinary, create_temp_file, doctest_namespace, lint, monkeypatch, paths, pytestconfig, record_property, record_xml_attribute, record_xml_property, recwarn, run_setup, tmpdir, tmpdir_factory
[task 2020-07-09T23:48:58.450Z] 0:34.58 > use 'pytest --fixtures [testpath]' for help on them.
[task 2020-07-09T23:48:58.450Z] 0:34.58
[task 2020-07-09T23:48:58.450Z] 0:34.58 /builds/worker/checkouts/gecko/tools/lint/test/conftest.py:68
[task 2020-07-09T23:48:58.450Z] 0:34.58 =========================== 8 error in 2.71 seconds ============================
[task 2020-07-09T23:48:58.450Z] 0:34.59 Return code from mach python-test: 1
[fetches 2020-07-09T23:48:58.584Z] removing /builds/worker/fetches
[fetches 2020-07-09T23:48:58.785Z] finished
[taskcluster 2020-07-09 23:48:59.185Z] === Task Finished ===
[taskcluster 2020-07-09 23:48:59.185Z] Unsuccessful task run with exit code: 1 completed in 174.054 seconds

Tom, do you have a few moments to look into this?
Thank you.

Flags: needinfo?(mozilla)

The root fixutre was accidentaly made not a fixture, due to a bad rebase.

Attachment #9162665 - Attachment description: Bug 1651867: Fix failing mozlint tests; r=me → Bug 1651867: Fix failing mozlint tests.
Duplicate of this bug: 1652185
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Regressions: 1652503
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

Clearing obsolete NI.

Flags: needinfo?(mozilla)
You need to log in before you can comment on or make changes to this bug.