Closed Bug 1652945 Opened 2 years ago Closed 7 months ago

Add AV1 hardware decoding support

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

x86_64
Windows 10
enhancement

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
relnote-firefox --- 100+
firefox100 --- fixed

People

(Reporter: ihdgma, Assigned: Zaggy1024)

References

(Blocks 2 open bugs)

Details

(Keywords: parity-chrome, parity-edge)

Attachments

(1 file, 1 obsolete file)

https://github.com/intel/media-driver/commit/9491998f40d496fc458d282f213c0e9e945b8062

"[Decode] This enables HW AV1 decode acceleration on Gen12"

Intel has AV1 fixed function hardware decoding in Gen12 integrated GPU shipping in Tiger Lake later this year and Rocket Lake whenever that is released, Mozilla should add AV1 hardware decoding support when possible.

https://bugzilla.mozilla.org/show_bug.cgi?id=1292374

Previous bug showing how VP9 fixed function hardware decoding support was added for reference.

Blocks: AV1
Type: defect → enhancement
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
See Also: → 1652958

Just a bit more info: YouTube seems roll all video above 2K to av1 instead of VP8/9 once before.

https://www.nvidia.com/en-us/geforce/news/rtx-30-series-av1-decoding/

Nvidia Ampere GPUs have AV1 hardware decoding, please add AV1 hardware decoding support to Firefox.

Nvidia: "Google has updated Chrome on Windows 10 to support AV1 hardware decoding"

https://newsroom.intel.com/news-releases/11th-gen-tiger-lake-evo/

"Support for the high-performance AV1 CODEC that enables power-efficient support for 4K, even in constrained bandwidth environments."

https://www.microsoft.com/en-us/download/details.aspx?id=101577

"This document is the specification for support of AV1 according to the AV1 video coding standard as published by the Alliance for Open Media within the Windows DirectX Video Acceleration (DXVA) API/DDI context. The document describes high-level design concepts and specific AV1 extensions to DXVA interfaces and data structures. This document specifies only off-host VLD profiles for AV1 decoding."

Per NVIDIA press at https://www.nvidia.com/en-us/geforce/news/rtx-30-series-av1-decoding/
NVIDIA started supporting av1 on RTX 30 series.

https://techcommunity.microsoft.com/t5/media-at-microsoft/av1-hardware-accelerated-video-on-windows-10/ba-p/1765451

Here are the components required to experience hardware accelerated AV1 video on Windows 10:

One of these new GPUs or CPUs:
    11th Gen Intel Core processors with Intel Iris Xe Graphics 
    NVIDIA GeForce RTX 30 Series GPUs
    AMD Radeon™ RX 6000 Series Graphics (coming soon)
Windows 10 build 1909 or later
The AV1 Video Extension
A web browser or other application with hardware acceleration support for AV1, including apps built on top of Media Foundation
As is common with new features like this, you may need to update your graphics driver from time to time to get the latest features and improvements.

Is this a dupe of bug 1652958, or is bug 1652958 a dependency of this bug?

Severity: -- → S3
Flags: needinfo?(bvandyk)
Priority: -- → P3

This depends on bug 1652958. VAAPI support will be one of the ways we can support hardware AV1, but is unlikely to be the avenue we take of Windows and MacOS.

Depends on: 1652958
Flags: needinfo?(bvandyk)

Windows HW media playback does not use VA-API / ffvpx so removing Bug 1652958.

No longer depends on: 1652958

Hardware support is still pretty limited, around 2% of the total ecosystem. Not a priority at this point.

Severity: S3 → S4
Assignee: nobody → Zaggy1024
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1757823

The method of creating decoder MFTs was replaced with MFEnumEx queries in order to get an instance of the AV1 decoder.

https://phabricator.services.mozilla.com/D138884

Attachment #9268348 - Attachment is obsolete: true
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90c92f9077fa
Added support for the Windows Media Foundation AV1 decoder for hardware decoding. r=alwu
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
Regressions: 1760804

Release Note Request (optional, but appreciated)
[Why is this notable]: Windows users with new enough GPUs will get hardware decoded AV1 video.
[Affects Firefox for Android]: Nope
[Suggested wording]: Hardware accelerated AV1 video decoding enabled on Windows with supported GPUs (Intel Gen 11+, AMD RDNA 2 Excluding Navi 24, GeForce 30)
[Links (documentation, blog post, etc)]:

You need to log in before you can comment on or make changes to this bug.