Open Bug 1452683 (AV1) Opened 4 years ago Updated 3 months ago

[meta] AV1 playback support

Categories

(Core :: Audio/Video: Playback, enhancement, P2)

enhancement

Tracking

()

People

(Reporter: drno, Assigned: drno)

References

(Depends on 8 open bugs)

Details

(Keywords: meta)

No description provided.
Depends on: 1452688
Depends on: 1474684
Depends on: 1475564
Depends on: 1476975
Alias: AV1
Depends on: 1417050
Duplicate of this bug: 1368838
Depends on: 1362465
Depends on: 1368843
Depends on: 1436511
Depends on: 1471535
Depends on: 1477420
Depends on: dav1d
Depends on: 1493611
Depends on: 1494493
Depends on: 1511438
Depends on: 1550568
See Also: → JPEG2000
See Also: JPEG2000
See Also: → AVIF

I believe we are using dav1d now. Should this be closed?

Flags: needinfo?(achronop)

This is a meta bug and there are a number of bugs which are still open that it depends on. For example, AV1 is not enabled on Android. I believe it will stay open.

Flags: needinfo?(achronop)

firefox 75.0 - can open and play webm/av1/opus without problems, if opened as a file or referenced by http link.

WEBM over HLS (as published by Emby, for example) does not work and Emby decides to transcode.
Also, probably related, https://alpha.html5test.com/ shows that the browser does not support "WebM with AV1 support"...

Can someone knowledgeable explain what is going on please?

Depends on: 1635296
Depends on: 1652945
Depends on: 1652958

There is an Android Bug 1518549 too

Depends on: 1672276
You need to log in before you can comment on or make changes to this bug.