Closed Bug 1653836 Opened 2 years ago Closed 2 years ago

Migration from Ver68.10 to 78.0 produced xml-error

Categories

(Thunderbird :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: cg21, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [addon: ???])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18362

Steps to reproduce:

Unclear: without requesting an update from ver68 to ver78 my girlfriend got the ver78 on July18. An xml-error was displayed, sending mails was not possible. Receiving mails was possible.

Actual results:

I tried to go back to ver68, which was denied, because ver78 changed the profile, which could not be undone.
I installed ver78 again, created a new profile. However: I need the ver68-profile, which I can't access because of the xml-error. Adressbook, calender, mails are inaccessible.

Expected results:

  1. Get a warning re update and a choice to not update.
  2. If updating without asking, the old profile should have been preserved and provided a means to go back.
  3. the migration of the profile should have worked. Sorry for the obvious.
    HOW can I access the old profile (mails, adressbook, rest)???

Here is, what TB shows, when I start it with the Profile-Manager:
"XML-Verarbeitungsfehler
Nicht definierte Entität
Adresse: Chrome://messenger/content/messenger.xhtml
Zeile Nr. 1638, Spalte 9 (row, col)
<toolbarbutton id=appmenu_customi (here is the frame of the window, which displays the message)
….."

Which means, that something has been changed within the profile.
Now I need the contents of the profile: mails, archives, contacts, calender
AND how to move them into a new profile.
How can I do this?


On a pleasant note some trivia:
Today my computer did upgrade Thunderbird to Ver.78 and it works fine.
No problems.
One difference between our computers: My one did not run Firefox - for whatever this means.

Blocks: tb78found

Thunderbird 78 is available only as manual download so far. Do you use some 3rd party update manager that pushed the update to your computers?

Did you try -safe-mode? (Help | Restart with Add-ons disabled)

You can use the old profile by running with --allow-downgrade.
For the "old data" that won't help - e.g. the address book was migrated to a new format. But if the migration failed for some reason I assume the old address book data is also there.

Component: Untriaged → General
Summary: Migration from Ver68.10 to 78.10 produced xml-error → Migration from Ver68.10 to 78.0 produced xml-error

Did not try --allow-downgrade due to "busy otherwise". Will try.
Dit not yet try -safe-mode. Will try.
Do I use these with Ver78 or old Ver68? If 68, can I run both versions, or do I need to uninstall the 78, reinstall 68, and thereafter reinstall 78?

If this does not help:
I still need the old eMails and archives.
There are probably large files where these things are stored in. Which files are this, and is it possible to recover the the access using only these files?

The addressbook has been recovered from a older backup.

As for the uninvited upgrade: Probably the Avira-Security did it, but I am not yet sure.

You try -safe-mode with whichever version is showing the xml error.

The versions can be installed side-by-side in different folders, but then you probably need to start with profile manager (-P) to select the right profile.

As the data is not fully backwards compatible, I'd recommend just using a backup if you want to go back. The mail data format didn't change - it's in your Mail/ or ImapMail/ folders in the profile.

This must be due to some add-on, and -safe-mode should help. Closing.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Whiteboard: [addon: ???]
You need to log in before you can comment on or make changes to this bug.