Closed Bug 1654003 Opened 3 months ago Closed 3 months ago

Add an API(s) to send email

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1545930

People

(Reporter: florian.unger, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.119 Safari/537.36

Steps to reproduce:

I want to implement an alternate send button in an addon.
This button should do some predefined changes to the email when the user clicks on it and then send the email.

With TB 52 it was possible to initiate the sending of an email by calling
window.opener.SendMessage();
but in the current Extensions API I can not find a method to do this.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1545930
You need to log in before you can comment on or make changes to this bug.