Closed Bug 16548 Opened 21 years ago Closed 20 years ago

[EVENTTARG] events going to wrong element: inline elements and overlap

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: dbaron, Assigned: joki)

References

Details

Attachments

(2 files)

See also the following bugs relating to events going to the wrong elements:
bug 1413, bug 12231, bug 12232.  In particular, this bug will act differently
when bug 12231 is fixed.

DESCRIPTION:  Since inline elements are all above block level elements (this is
because of the rules for z-order around floats), the events should go to inline
elements, since they're on top.

STEPS TO REPRODUCE:
 * load attached test case
 * hover over / use the links

ACTUAL RESULTS:
 * the link on the bottom doesn't work in its first line or part of its second
 (note that when bug 12231 is fixed, the problem will occur with the link on the
top instead)

EXPECTED RESULTS:
 * the links work, since a block level element should only recieve events if
there are no inline elements at that position (assuming everything is in the
normal flow,... it's more complicated with positioning).

DOES NOT WORK CORRECTLY ON:
 * Linux, viewer, 1999-10-15-11-M11

WORKS CORRECTLY ON:
 * most other browsers, I think

ADDITIONAL INFORMATION:
See also http://www.w3.org/Style/ and http://www.w3.org/Style/CSS/ , where this
causes problems.
Layout problem is bug 18187.
Target Milestone: M13
Summary: events going to wrong element: inline elements and overlap → [EVENTTARG]events going to wrong element: inline elements and overlap
Summary: [EVENTTARG]events going to wrong element: inline elements and overlap → [EVENTTARG] events going to wrong element: inline elements and overlap
*** Bug 23190 has been marked as a duplicate of this bug. ***
Target Milestone: M13 → M16
Moving M16.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed
Keywords: verifyme
Verified fixed.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.