Closed Bug 18187 Opened 20 years ago Closed 20 years ago

[BLOCK] negative margin-bottom not working

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

(Keywords: css1, regression, testcase)

Attachments

(1 file)

DESCRIPTION:  The negative margin-bottom in the test case to be attached
recently stopped working (see below).  The test case is simplified from the one
in bug 16548.

STEPS TO REPRODUCE:
 * load attached test case

ACTUAL RESULTS:
 * first paragraph comes before second paragraph - the spacing looks normal

EXPECTED RESULTS:
 * second paragraph should be above first

DOES NOT WORK CORRECTLY ON:
 * Linux, viewer, 1999-10-26-08-M11
 * Linux, apprunner, 1999-11-04-08-M11

WORKS CORRECTLY ON:
 * Linux, viewer, 1999-10-25-16-M11
I think this may be a dup of bug 18050, but that doesn't mention that it's a
regression and it's filed on Style System.
Assignee: troy → kipp
Updating to default Layout Assignee...kipp no longer with us :-(
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.
Depends on: 18050
Summary: margin not working (regression) → [BLOCK] margin not working (regression)
Summary: [BLOCK] margin not working (regression) → [BLOCK] {css1} negative margin-bottom not working (regression)
Slightly increasing the detail on the summary. David: If I misunderstood the
bug, feel free to flame me and I'll change it back. ;-)
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Whiteboard: [TESTCASE]
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
QA Contact: petersen → chrisd
Keywords: regression
Summary: [BLOCK] {css1} negative margin-bottom not working (regression) → [BLOCK] negative margin-bottom not working
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16
Important to get this right, but won't make beta2.  Moving to M18.
Status: NEW → ASSIGNED
Target Milestone: M16 → M18
redistributing bugs across future milestones, sorry for the spam
Target Milestone: M18 → M19
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Target Milestone: M19 → Future
Nominating for nsbeta2 to bring this to the attention of the PDT. This is a 
CSS1 compliance issue. We are currently buggy.
Keywords: nsbeta2
OS: Linux → All
Hardware: PC → All
Whiteboard: [TESTCASE]
Since this is not a top100 bug (and because David suggested it) I am moving this
from nsbeta2 nomination to nsbeta3 nomination. Since this actually works in IE5,
to some extent, as well as being buggy CSS1 behaviour, I believe this should be 
an nsbeta3 blocker.
Keywords: nsbeta24xp, nsbeta3
Stealing and...
Assignee: buster → dbaron
Status: ASSIGNED → NEW
...marking fixed.  Same problem as bug 18050.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Verified.
Windows: 2000-07-13-09-M17
Linux:   2000-07-13-08-M17]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.