Closed Bug 1654902 Opened 2 months ago Closed 2 months ago

Perma xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_amo_stats_telemetry.js | xpcshell return code: 0 when Gecko 80 merges to Beta on 2020-07-27

Categories

(Toolkit :: Add-ons Manager, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 + verified

People

(Reporter: aryx, Assigned: willdurand)

References

(Regression)

Details

Attachments

(1 file)

central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=28460f5682b430c9da8c6c99a54574037cfb6b30&selectedTaskRun=C-7EggirR4yxiBNfJHJ-EQ.0

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=310841351&repo=try

[task 2020-07-23T13:09:51.500Z] 13:09:51 WARNING - TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_amo_stats_telemetry.js | xpcshell return code: 0
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - TEST-INFO took 463ms
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - >>>>>>>
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - running event loop
[task 2020-07-23T13:09:51.500Z] 13:09:51 INFO - xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_amo_stats_telemetry.js | Starting setup
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - (xpcshell/head.js) | test setup pending (2)
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - "CONSOLE_MESSAGE: (info) UpdateUtils.getAppUpdateAutoEnabled - Unable to read app update configuration file. Exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 74" data: no]"
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - "CONSOLE_MESSAGE: (error) [JavaScript Error: "UpdateUtils.getAppUpdateAutoEnabled - Migration failed. Exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 74" data: no]" {file: "resource://gre/modules/UpdateUtils.jsm" line: 237}]
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - getAppUpdateAutoEnabled/readPromise<@resource://gre/modules/UpdateUtils.jsm:237:18
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - _do_main@Z:\task_1595508858\build\tests\xpcshell\head.js:248:6
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - _execute_test@Z:\task_1595508858\build\tests\xpcshell\head.js:577:5
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - @-e:1:1
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - "
[task 2020-07-23T13:09:51.501Z] 13:09:51 INFO - PID 12828 | JavaScript error: resource://gre/modules/AddonManager.jsm, line 1475: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - Unexpected exception NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - callManagerListeners@resource://gre/modules/AddonManager.jsm:1475:24
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - startup@resource://gre/modules/AddonManager.jsm:830:10
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - startup@resource://gre/modules/AddonManager.jsm:3462:26
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - observe@resource://gre/modules/addonManager.js:87:29
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:1001:34
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - startAddonManager@resource://testing-common/ExtensionXPCShellUtils.jsm:993:27
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - setup@Z:/task_1595508858/build/tests/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_amo_stats_telemetry.js:27:28
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - _do_main@Z:\task_1595508858\build\tests\xpcshell\head.js:248:6
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - _execute_test@Z:\task_1595508858\build\tests\xpcshell\head.js:577:5
[task 2020-07-23T13:09:51.502Z] 13:09:51 INFO - @-e:1:1
[task 2020-07-23T13:09:51.503Z] 13:09:51 INFO - exiting test

Flags: needinfo?(wdurand)
Flags: needinfo?(wdurand)
Flags: needinfo?(wdurand)

So it looks like something isn't correctly initialized and that breaks the initialization of AddonManager. Looking at other test files, we should probably use AddonTestUtils.createAppInfo() at the top of the file to ensure valid app info.

Assignee: nobody → wdurand
Flags: needinfo?(wdurand)
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/871efea5afff
Create appInfo to correctly initialize AddonManager. r=rpl
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.