Closed Bug 1655244 Opened 4 years ago Closed 4 years ago

Ctrl+scroll wheel does not zoom in Thunderbird message reader, message pane or compose window

Categories

(Thunderbird :: Mail Window Front End, defect, P1)

Tracking

(thunderbird_esr78+ fixed, thunderbird80 fixed)

VERIFIED FIXED
81 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird80 --- fixed

People

(Reporter: mkmelin, Assigned: khushil324)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #1634556 +++

Splitting off the Thunderbird part to this bug. See bug 1634556 comment 11:

Thunderbird doesn't use e10s yet. The compose content is in an <editor> https://searchfox.org/comm-central/rev/eb69eff3ca16509af6cf8f2dd29be396bebbc14d/mail/components/compose/content/messengercompose.xhtml#2526 and the viewing content in a <browser> https://searchfox.org/comm-central/rev/eb69eff3ca16509af6cf8f2dd29be396bebbc14d/mail/base/content/messenger.xhtml#769

I see we have a forked ZoomManager. That might need needs adjustments - https://searchfox.org/comm-central/search?q=ZoomManager&path=

If there's a Thunderbird developer who is prepared to do the work, the https://phabricator.services.mozilla.com/D84767 patch shows what needs to be done:

On the parent process, listen for the "DoZoomEnlargeBy10" and ""DoZoomReduceBy10" events, and either set browser.fullZoom (if you have a browser) or docShell.zoom in increments of 0.1.
Cap the zoom levels based on the prefs "zoom.minPercent" and "zoom.maxPercent". The D84767 patch gets these values from ZoomManager, but that's not strictly necessary, and they can be retrieved using more direct means.
Attachment #9166386 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Comment on attachment 9166386 [details] [diff] [review]
Bug-1655244_ctrl-scroll-zoom-not-working-0.patch

Review of attachment 9166386 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thx! r=mkmelin
A small unbitrotting was necessary
Attachment #9166386 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → 81 Branch

[Approval Request Comment]
Regression caused by (bug #): 1516413
User impact if declined: User will not be able to zoom in or out with scroll event. It can impact the experience of users who were relying on scroll events to change the zoom while reading the mail.
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky): Low.

Attachment #9166386 - Attachment is obsolete: true
Attachment #9167672 - Flags: review+
Attachment #9167672 - Flags: approval-comm-esr78?
Attachment #9167672 - Flags: approval-comm-beta?
Blocks: tb78found

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/9d32224ed772
Fix Ctrl+scroll wheel does not zoom in Thunderbird message reader, message pane or compose window. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 9167672 [details] [diff] [review]
Bug-1655244_ctrl-scroll-zoom-not-working-1.patch

[Triage Comment]
Approved for beta
Attachment #9167672 - Flags: approval-comm-beta? → approval-comm-beta+

Working in my testing of the 80.0b2 release candidate on Ubuntu 18.04.4.

Comment on attachment 9167672 [details] [diff] [review]
Bug-1655244_ctrl-scroll-zoom-not-working-1.patch

[Triage Comment]
Approved for esr78

Attachment #9167672 - Flags: approval-comm-esr78? → approval-comm-esr78+
Status: RESOLVED → VERIFIED

This should have been fixed for the message source window as well:
https://github.com/Betterbird/thunderbird-patches/blob/main/91/bugs/1655244-ctrl-scroll-source.patch

Flags: needinfo?(mkmelin+mozilla)
See Also: → 1749305

Filed bug 1749305 for that.

Flags: needinfo?(mkmelin+mozilla)

Comment on attachment 9258333 [details]
Bug 1655244 - Fix Ctrl+scroll wheel zoom in message source window. r=henry

Revision D135511 was moved to bug 1749305. Setting attachment 9258333 [details] to obsolete.

Attachment #9258333 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: