Closed Bug 1655884 Opened 2 years ago Closed 2 years ago

"Always prefer display name over message header" checkbox is always checked

Categories

(Thunderbird :: Address Book, defect)

defect

Tracking

(thunderbird_esr68 wontfix, thunderbird_esr78 fixed, thunderbird80 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr68 --- wontfix
thunderbird_esr78 --- fixed
thunderbird80 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

Details

(Keywords: regression)

Attachments

(1 file)

I think this got broken when we first linted abCard.js. We made one attempt to fix it at the time but it's still broken.

This puts the line back to how it was before we added linting. Obviously the linting change and the follow-up fix were both bogus.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/7405c52008fe
Fix "Always prefer display name over message header" checkbox. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Attachment #9166718 - Flags: approval-comm-beta?

Comment on attachment 9166718 [details]
Bug 1655884 - Fix "Always prefer display name over message header" checkbox. r?aleca

[Triage Comment]
Approved for beta

Attachment #9166718 - Flags: approval-comm-beta? → approval-comm-beta+

Looks good to me in my testing of the 80.0b2 release candidate on Ubuntu 18.04.4.

Attachment #9166718 - Flags: approval-comm-esr78?
Keywords: regression

Comment on attachment 9166718 [details]
Bug 1655884 - Fix "Always prefer display name over message header" checkbox. r?aleca

[Triage Comment]
Approved for esr78

Attachment #9166718 - Flags: approval-comm-esr78? → approval-comm-esr78+
Status: RESOLVED → VERIFIED

Still being always checked in my testing of the 78.2.0 release candidate on Ubuntu 18.04.5 LTS. New profile.

Helps to test the correct build.

Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Well, maybe we should clarify the desired behaviour first because imho the design is inherently garbled and mutilated.
We have a global pref controlling the same behaviour: Show only display name for people in my address book.
Iiuc, here we have a per-card pref which is supposed to override the global behaviour.
If I don't change the card pref, it should use the global default, isn't it?
So what is the difference in UI state between per-card custom setting and "use global setting"? Can't tell.

Clearly, the interaction of global and per-card pref can never work correctly and predictably unless per-card pref is triple:

  • Use global pref
  • Prefer display name from address book over message header
  • Prefer message header over address book display name
    Internally, use a number pref which can be set to 0, 1, and 2.

And what if I want the display name from my AB AND the email address?

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.