Closed Bug 1656922 Opened 4 months ago Closed 4 months ago

Address field is not filled by autofill in BestBuy

Categories

(Toolkit :: Form Autofill, defect)

defect

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- disabled
firefox81 --- verified

People

(Reporter: bogdan_maris, Assigned: abr)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Gif showing the issue

Affected versions

  • Latest Nightly 81.0a1
  • Firefox Beta 80.0b3

Unaffected versions

  • Firefox 79.0 RC

Affected platforms

  • Windows 10 64bit

Steps to reproduce

  • Have one address saved. Have the following prefs: extensions.formautofill.available - on and extensions.formautofill.creditCards.available - true
  1. Start Firefox
  2. Visit https://www.bestbuy.com/
  3. Add a product in Cart and go to checkout as Guest
  4. Click on First Name field and select an entry.

Expected result

  • Address field is filled by selecting an entry from autofill.

Actual result

  • Address field is not filled when selecting an entry from autofill, even more, if clearing the other entries, autofill can't be used anymore (page refresh is required to make it work again).

Suggested Severity

  • I suggest to mark this as a S2 severity since it impacts a highly used shopping website and based on the fact that the user will have to refresh the checkout page in order to make the autofill work again.

Regression range

Additional notes

  • Gif showing the issue is attached. Left - Good build, Right - Bad build.
Flags: needinfo?(adam)
Has Regression Range: --- → yes
Has STR: --- → yes
Whiteboard: [ccautofill]

Thanks for tagging me, Bogdan. This is a kind of perplexing effect from the change you point to, but I agree that it's a prime suspect. At the moment, I don't have any theories about why this is happening, so it'll require additional debugging. I'm clearing my ni? to let this go through the normal triage process.

Flags: needinfo?(adam)

Not cc autofill related.

Summary: Address field is not field by autofill in BestBuy → Address field is not filled by autofill in BestBuy
Whiteboard: [ccautofill]
Depends on: 1658086

Fixed by Bug 1658086

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Assignee: nobody → adam
Target Milestone: --- → 81 Branch

Verified - Fixed in latest Nightly 81.0a1 (build id: 20200813092915) using Windows 10, Ubuntu 18.04 and Mac OS 10.13. All the expected fields are autofilled now. Works fine after clearing the other entries as well.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.