Closed Bug 1657034 Opened 2 years ago Closed 2 years ago

Sort by correspondents hangs

Categories

(Thunderbird :: Message Reader UI, defect)

Unspecified
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1657565

People

(Reporter: erdunlap, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: hang)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.2 Safari/605.1.15

Steps to reproduce:

try to sort by correspondents

Actual results:

it crashed, on iMac spinning ball and 'not responding'

Expected results:

it should sort

wfm on Win10, 78.1.0 (64-bit), but reported against Mac.

  • Eugen, can you share Crash report from Help > Troubleshooting information > Crash Reports for the Last 3 Days?
  • anything in error console?
  • does this happen in TB safe mode (restart with addons disabled)?
Flags: needinfo?(erdunlap)
Component: Untriaged → Message Reader UI
OS: Unspecified → iOS 10
Summary: can't sort by correspondents → Sort by correspondents crashes

"Mac spinning ball and 'not responding'" is a hang, not a crash ;)
(In the Mac world, hangs are routinely referred to as crashes for some odd reason)

Keywords: hang
OS: iOS 10 → macOS
Summary: Sort by correspondents crashes → Sort by correspondents hangs

started in TB safe mode, the same thing. There is no crash report from the last 3 days; all very much older.
So when I try to sort my email by 'correspondents' I get a spinning Apple ball. Can't do anything until I force quit application and restart. At moment I am not using this way of sorting to avoid the problems. TB 78.1.0 on iMac 10.15.6

Flags: needinfo?(erdunlap)

Eugen, pls do this:

  1. In "Local Folders" account (bottom of folder list), create a folder named "Test".
  2. copy 3 messages with different correspondents into "Test" folder (or, for perfect testing, create new messages with simple recipient names like John Doe, Jane Doe, and Tim Test, and copy them over from draft folder).
  3. Show correspondents column if not shown yet, then try to sort as you did in the fail case.
  4. Report success or fail here.

Btw, any special characters in your correspondents, accented, unicode emojis or the like?

Flags: needinfo?(erdunlap)

(In reply to Wayne Mery (:wsmwk) from comment #2)

"Mac spinning ball and 'not responding'" is a hang, not a crash ;)
(In the Mac world, hangs are routinely referred to as crashes for some odd reason)

Mac crashes must go hang! ;-)

Blocks: tb78found

We'll cover this in bug 1657565

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(erdunlap)
Resolution: --- → DUPLICATE
Duplicate of bug: 1657565
You need to log in before you can comment on or make changes to this bug.