Closed Bug 1657676 Opened 4 months ago Closed 2 months ago

Update keywordoffer results for search mode

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement
Points:
2

Tracking

()

RESOLVED FIXED
82 Branch
Iteration:
82.2 - Sep 7 - Sep 20
Tracking Status
firefox82 --- fixed

People

(Reporter: harry, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

When "@" is typed, we show all the user's token alias engines. The results read @enginename — Search with Enginename. Since @ results are mostly being superseded by update2's search mode, we should discuss changing the look of these results with UX.

Maybe we could just show normal keyword offer engine results. That is, all the results for the "@" query just read Search with Enginename. As the user moves through the results, we could add/change the search mode indicator instead of autofilling @enginename. This would be similar to how we're planning to handle tab-to-complete results.

Severity: -- → S3
Priority: -- → P2
See Also: → 1647926

I'll focus this bug on just cycling through search modes as the user moves through keywordoffer results. We will enter the keywordoffer's search mode without executing a new query. As the user continues moving through results and leaves the keywordoffer, we will restore text to the Urlbar from UrlbarInput._getValueFromResult.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 82.2 - Sep 7 - Sep 20
Attached image cycling.jpg

UX confirms that we should drop the @alias from the result title when the user types @. When the user cycles through the results, we should enter search mode without executing a new query (i.e. show the search mode indicator and do nothing else).

Keywords: blocked-ux
Summary: Update token alias results to support search mode → Update keywordoffer results for search mode

We should do the same thing for keywordoffer Top Sites, per the drawing.

See Also: → 1664320
Attachment #9175284 - Attachment description: Bug 1657676 - Add search mode preview and enter it when a keywordoffer result is selected. → Bug 1657676 - Add search mode preview.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
No longer blocks: 1665908
Regressions: 1666927
Blocks: 1647926
See Also: 1647926
Attached image F83

Hi,
I just verified this and I noticed that when I type @, bookmarks, tabs and history are not shown on the list as was shown in cycling.jpg.
Was this intended? This happens both in FF83 and 84.

Regards, Flor.

Flags: needinfo?(htwyford)

Thanks for finding this. I'm not 100% sure what UX thinks here so I'll ask them in our next meeting. I'll keep the needinfo as a reminder to come back to this.

Blocks: 1675048

UX still wants Bookmarks, History, and Tabs to appear for searches for "@". Thanks again for reporting this, Flor. I filed bug 1675048.

Flags: needinfo?(htwyford)

Awesome, thanks to you for asking ux and for filing the new bug :)

You need to log in before you can comment on or make changes to this bug.