Closed Bug 1657694 Opened 1 year ago Closed 9 months ago

Bugzilla scrollbars are missing arrows when native theme is disabled

Categories

(Core :: Widget: Win32, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M7
Tracking Status
firefox81 --- affected

People

(Reporter: cpeterson, Unassigned)

References

Details

Attachments

(1 file)

Attached image Bugzilla_scrollbar.jpg

Steps to reproduce

1 Set widget.disable-native-theme-for-content pref = true.
2. Load a Bugzilla bug.
3. Scroll the page using the scrollbar.

Expected result

The page's scrollbar should have arrows at the top and bottom.

Actual result

The page's scrollbars are missing arrows when native theme is disabled. See the attached screenshot.

I'm running Fx81 Nightly on Windows 10.

Is this true for all scrollbars? Or only on Bugzilla?

Flags: needinfo?(cpeterson)

(In reply to Stephen A Pohl [:spohl] from comment #1)

Is this true for all scrollbars? Or only on Bugzilla?

I've only seen this problem on Bugzilla. Note that Bugzilla's scrollbar appear to be limited to just the page's <main> element instead of the full page, so there might be some different styling logic involved.

Flags: needinfo?(cpeterson)

The severity field is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Severity: -- → S2
Priority: -- → P2
Flags: needinfo?(jmathies)
Blocks: win-nnt
No longer blocks: 1615105

Tracking non-native theming bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7

Chris, would you be able to check if this is fixed in this try build? Thank you!

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Zy9lK9zaQHqFUq7xSbybGw/runs/0/artifacts/public/build/setup.exe

Flags: needinfo?(cpeterson)

(In reply to Stephen A Pohl [:spohl] from comment #5)

Chris, would you be able to check if this is fixed in this try build? Thank you!

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Zy9lK9zaQHqFUq7xSbybGw/runs/0/artifacts/public/build/setup.exe

Closing as WORKSFORME. I now see the Bugzilla scrollbar's arrows in regular Nightly builds (with widget.disable-native-theme-for-content enabled). I suspect the Bugzilla web design may have changed because my attached screenshots show the scrollbar below the gray page header and I now see the scrollbar to the right of the gray page header.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.