Closed Bug 1657893 Opened 9 months ago Closed 9 months ago

./mach bootstrap fail on macOS 11 (Big Sur)

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

x86_64
macOS
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jya, Unassigned)

References

(Blocks 1 open bug)

Details

Step to reproduce:

  • Install MacOS Big Sur Beta 4
  • Install XCode 12.0 beta 4
  • Run Xcode to accept the license agreement and install command line tools.

now attempt to run ./mach bootstrap ; will fail after attempting to run brew install llvm

it takes about 1h on my MBP 15" late 2018 before llvm build fails as the failure is happening at 91% in the build when attempting to link.

Not sure why bootstrap attempt to install/build llvm via brew rather than download it like it usually does.

Blocks: mach-busted

Can you attach the full log from ./mach bootstrap?

What version of the code are you running? We shouldn't be installing llvm via brew since bug 1472091.

Flags: needinfo?(jyavenard)

Don't know what I did. But today everything is working fine.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(jyavenard)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.