Closed Bug 165809 Opened 19 years ago Closed 19 years ago

Mozilla ignores all Mac OS X System Preferences for Internet settings and applications.

Categories

(SeaMonkey :: Preferences, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 5721

People

(Reporter: Xapplimatic, Assigned: bugs)

References

Details

(Keywords: imap-interop, l12y)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

Mac OS X System Preferences: In the Internet pane there are designations for
default home page, web browser, mail client, and news client.  IE 5.2 for OS X
(most current IE) and all prior versions pass the mailto: address out to the
program System Preferences is set to for handling by default.  IE also takes its
home page default from System Preferences as well as news: handling application.
 Mozilla should also default to using the system preference for all these, but
could also allow the user to set a selection to use the internal mail/news
client or to bring up a file requestor to pick another application, or an "Ask"
setting which gives the option at each instance in leiu of a set preference.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Mozilla should by default accept all Internet related settings from Mac OS X
System Preferences including default home page and mail / news protocal handling
applications.

Similar to bug #11459 yes, but more broad..  More than just concerning mailto:
link handling, Mozilla should respect system preferences in all cases by default
unless directed otherwise..
Depends on: 11459
Keywords: interop, l12y, mail4
Bug 5721 is a general bug about the internet settings. Check the dependancy tree
for all the prefs you mention here.

*** This bug has been marked as a duplicate of 5721 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Depends on: 5721
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.