Closed Bug 5721 Opened 23 years ago Closed 16 years ago

Need more Mac Internet Config support

Categories

(SeaMonkey :: Preferences, defect, P2)

PowerPC
All
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: petitta, Assigned: samir_bugzilla)

References

(Depends on 2 open bugs)

Details

(Keywords: helpwanted, meta, platform-parity, Whiteboard: [se-radar])

Attachments

(1 obsolete file)

(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #350765
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=350765
Imported into Bugzilla on 04/29/99 13:36)

Mac Internet Config support for Communicator 5.0.

John you suggested Component = libPref, but I'm unable to find libPref in the
component list.  Please adjust if need be.
OS: All
Summary: Need Mac Internet Config support for Communicator 5.0.
cc sfraser
Priority: P3 → P2
Target Milestone: M7
Do we need to do this earlier or later than M7.
Accepting
Target Milestone: M7 → M8
QA Contact: 3819
Summary: Need Mac Internet Config support for Communicator 5.0. → [PP]Need Mac Internet Config support for Communicator 5.0.
Assignee: mcmullen → sdagley
Status: ASSIGNED → NEW
sdagley.
Status: NEW → ASSIGNED
Target Milestone: M8 → M11
Target Milestone: M11 → M14
post "beta"
mass moving m14 bugs to m15
[added depends relationships for specific Internet Config support bugs]
Keywords: pp
Summary: [PP]Need Mac Internet Config support for Communicator 5.0. → Need Mac Internet Config support for Communicator 5.0.
Moving all libPref component bugs to new Preferences: Backend component.  
libPref component will be deleted.
Component: libPref → Preferences: Backend
Shouldn't someone in XPApps have this?
assign -> phil, cc don
Assignee: sdagley → phil
Status: ASSIGNED → NEW
I'm sure eli would love to own this bug on the qa side
QA Contact: paulmac → elig
Peter, I think you're right.  Reassigning to you.  Marked M16 to get off M15 radar.
Assignee: phil → trudelle
Target Milestone: M15 → M16
Sorry, meant to send that to Don but my brain is still in bed (where I should be.)
Assignee: trudelle → don
Keywords: nsbeta2
Putting on [nsbeta2+][5/16] radar.  This is a feature MUST complete work by 
05/16 or we may pull this feature for PR2.
Summary: Need Mac Internet Config support for Communicator 5.0. → Need Mac Internet Config support for Netscape 6
Whiteboard: [nsbeta2+][5/16]
Hold on to this until pchen arrives on May 30 ...
Move to M19.
Target Milestone: M16 → M19
Putting on [nsbeta2-] radar.  Removing 5/16...did not make Netscape 6 feature 
train.  Please move to MFuture.
Whiteboard: [nsbeta2+][5/16] → [nsbeta2-]
Depends on: 43585
Waitaminute!  We're doing this for helper apps in bug #43585.  So some form of
Internet Config support is going into NS6.  I think this is a dup.



*** This bug has been marked as a duplicate of 43585 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Target Milestone: M19 → ---
Verified duplicate.
Status: RESOLVED → VERIFIED
I'm reopening. There is more to IC support than helper apps. We should also be 
getting the following settings from IC, either 'live', or as defaults for a new 
profile:

1. Full naame
2. Email address
3. Email password
3. Organization
4. Email signature
5. Mail server, SMTP server (sadly, IC does not store server type)
6. Home page URL, search page URL
7. Download folder
8. Links colors
9. Underline links pref
10. News server, and news authentication info
11. Whether to use passive FTP (if applicable)
12. File mappings (file extension -> creator/type, whether to transfer in
    binary mode, and how to handle on download (e.g. open with application).
13. Firewall info (SOCKS server, proxy servers)
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
add self to cc
Internet Config support should be live. It should not simply be used as defaults 
for a new profile. The whole point of Internet Config support is to make it 
simple to change all Internet settings quickly, globally across all programs 
running on a Mac. Plus, for those who have PowerBooks, Location Manager is an 
indispensible utility which can change Internet control panel configurations 
quickly, making it easy to use a PowerBook with multiple Internet settings at 
multiple locations.

- Adam
pchen, can you take a look?
Assignee: don → pchen
Status: REOPENED → NEW
Target Milestone: --- → Future
Yeah, would be nice...
Status: NEW → ASSIGNED
Can someone nominate for nsbeta3 in line with other internet config bugs?
This should also be 4xp as Nav4 had limited Internet Config support for mail and 
news, and Moz doesn't even have that.

The problem with the 4.0 implementation is that Nav4 insisted on keeping its own 
settings seperately. IC support was either on or off in the preferences globally, 
which the overrode Nav4's own setting which was/is just plain confusing. If it 
exists it needs to be both always on and transparent.

In my personal opinion, IC support is the single most important Mac-likeness fix. 
(well OK, maybe after the classic skin!)
This came up as a Mac issue, putting in nsmac2.
Keywords: nsbeta3, nsmac2
nav triage team:
nsbeta3-
The most important stuff of internet config is nsbeta3+ in bug 43585.  The delta
this bug covers is something we can live without.
Summary: Need Mac Internet Config support for Netscape 6 → Need more Mac Internet Config support for Netscape 6
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
[Months after Eli stopped working on Mozilla, there are still open bugs with him 
as the QA contact. Fantastic ...]
QA Contact: elig → sairuh
Summary: Need more Mac Internet Config support for Netscape 6 → Need more Mac Internet Config support
adding myself to CC - paul, I'd like to talk with you a little about this on
tuesday
Why is this futured? It appears to be the only Internet Config bug we have and 
Internet Config support remains terrible... 

This is suffering from having too many bugs in one bug. See Simon Fraser's 
2000-07-17 10:54  comment for illustrations. I think I'll break it out into 
actual individually solvable issues. Also bug 43585 has a whole bunch of 
unresolved stuff just sloshing around in the comments. 

Lets see what I can do to make the scope of the problem clear.
Whiteboard: [nsbeta2-][nsbeta3-]
Depends on: 63197
Depends on: 68513
Depends on: 68514
Depends on: 68515
*** Bug 69108 has been marked as a duplicate of this bug. ***
Mozilla should also go to Internet Config to get MIME types for outgoing
attachments. See bug 70222.
nav pretriage:

There are too many things to add for full IC support especially for the beta1 
timeframe. Turning this into a meta/tracking bug. Removing nsbeta1 keyword and 
adding meta keyword.
Keywords: nsbeta1meta
Adding 49758 to dependency list
Depends on: 49758
*** Bug 81354 has been marked as a duplicate of this bug. ***
Why hasn't this been fixed yet? It's been over two years since it was originally reported?
Well - perhaps because "more" is a relative expression? In fact, Internet Config
support seems to be there, to a some degree. Just try to install Mozilla
*without* the Mail/News portion, and you will see that clicking on mailto:urls
will open a message in your Internet Controlpanel/IConfig mailer application.
I see some Inter Config support has been put in Mozilla Good Work!

Next Step

I suggest you next add support for the prozy settings from Inter Config
*** Bug 90917 has been marked as a duplicate of this bug. ***
Blocks: 97214
No longer blocks: 97214
Depends on: 97214
-> default assignee
Assignee: pchen → sgehani
Status: ASSIGNED → NEW
Component: Preferences: Backend → Preferences
Target Milestone: Future → ---
Over to sfraser for some mac expertise.
Assignee: sgehani → sfraser
Not so fast, young grasshopper!

Some of this stuff is already done. I would recommend that you go through the 
list in comment 20, see which of those still are not using IC, and file new bugs 
on each one.
Assignee: sfraser → sgehani
Keywords: helpwanted
Target Milestone: --- → Future
Per comment 42, to what level of granularity should these bugs be created? There
are Internet preferences categories (Email, Web, and News), subcategories
(Web/Default Pages, Web/Colors & Links, etc.), and even sub-subcategories
(Web/Colors & Links/Unread, Web/Colors & Links/Read, etc.)

Also, should this be restricted to bugs about taking data from the internet
preferences panel or pane, or should it be enlarged to include other
system-level preferences (like proxies on OS X, which comes from Networking)?

I've made a list of potential bugs, and there will be at least 20 so far.
Depends on: 161780
Comment 22, about live IC support, makes me somewhat disturbed. It is true that
such a convenience is many a times practical, but it is also true that people do
keep separat settings and identities for different browsers.

Therefore, a preference to overrule IC is much desired.

I may have a home page specified in IC, and this may or may not be changed by
predator applications like IE (to msn.com), but it mustn't necessarily be the
home page I prefer for Mozilla (it could be the daily buglist, a localhost
version of my own home page, or something else).

Maybe I use Mozilla for testing, and therefore keep it in vanilla state with
underlined links and so on, but prefer another browser for actual surfing?

Maybe I do use Mozilla's mailer for a school account, and a dedicated mailer for
other stuff? I wouldn't necessarily want Mozilla to change in any way just
because my ISP has a new SMTP server.
Regarding comment 22 and 44, it is my intention to file a bug requesting a
preference to lock or unlock a profile to IC.
*** Bug 165809 has been marked as a duplicate of this bug. ***
Blocks: 165809
QA Contact: sairuh → petersen
Whiteboard: [se-radar]
Could you fix converting names from MacRoman charset to what ever is used in
Mozilla... Many French names contain diacritical marks.
Comment on attachment 106513 [details]
New account with non ascii chars snapshot

Attachment isn't relevant to this bug.
Attachment #106513 - Attachment is obsolete: true
Mozilla 1.2b Release Notes extract:

Mac OS: Non-ASCII non-Latin 1 info stored in Internet Config will not show
correctly in auto-fill fields such as "Your name" field in the Mail account
setup dialog. If this happens, you can manually correct auto-filled entries.
(Bug 5721)

My attachment depicted exactly the problem described in the release notes, that
link to this bug page.

http://www.mozilla.org/releases/mozilla1.2b/
Depends on: 217605
Product: Browser → Seamonkey
165809 is marked as both a duplicate and a blockee.  Blocking of bug 165809 to
be removed or bug 165809 unmarked as a duplicate.  (or close this bug - which
seems to have been abandoned, as it's very outdated)
Internet config is dead.
Status: NEW → RESOLVED
Closed: 22 years ago16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.