Closed Bug 1658165 Opened 1 year ago Closed 1 year ago

Pressing esc while in print preview closes the print preview for other tabs as well

Categories

(Toolkit :: Printing, defect, P1)

Firefox 81
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox81 --- verified

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Fixed by 1653317])

Attachments

(1 file)

Attached image printesc.gif

Affected versions

  • 81.0a1 (BuildId:20200804215246)

Affected platforms

  • Windows 10 64bit
  • macOS 10.14

Unaffected platforms

  • Ubuntu 18.04 64bit (will confirm this on Monday)

Steps to reproduce

  1. Launch Firefox.
  2. Open two tabs containing two different webpages.
  3. Open the print preview on both tabs.
  4. Press the escape keyboard button in one tab.
  5. Observe the second tab.

Expected result

  • Only the print preview for the tab where the esc keyboard button was pressed gets dismissed.

Actual result

  • The print preview gets dismissed for all tabs.

Regression Range

  • I don’t think that this is a regression.

Notes

  • Please observe the attached screencast for further information regarding this issue.
  • There seems to be a difference between dismissing the print preview via escape keyboard button and the “Cancel” button (from the print preview). It seems that clicking the cancel button dismisses only the print preview from the tab where this action was performed (not affecting print preview on other tabs) but pressing the escape button affects the print preview for other tabs as well.
Whiteboard: [print2020_v81]
Has STR: --- → yes
Blocks: 1658287

It looks like switching to TabDialogBox in bug 1653317 will remove the automatic support for the escape key closing the dialog. We'll likely need to reimplement that.

Bug 1658101 also points out that command+. should close the dialog on macOS. May as well do that here, but I'm going to leave that bug open for now in case the escape functionality ends up being handled by TabDialogBox once it's ready.

Severity: -- → S3
Depends on: 1653317
Priority: -- → P1
See Also: → 1658101

This is fixed by TabDialogBox

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1650795
Duplicate of bug: 1653317
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

(This should be fixed by bug 1653317 so removing the [print2020_v81] whiteboard tag for easier tracking.)

Whiteboard: [print2020_v81]

And now that bug 1653317 has landed, this should be fixed. :)

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED

This is verified fixed using Firefox 81.0a1 (BuildId:20200820212107) on Windows 10 64bit, macOS 10.14 and Ubuntu 20.04

Status: RESOLVED → VERIFIED
Whiteboard: [Fixed by 1653317]
You need to log in before you can comment on or make changes to this bug.