Closed Bug 1653317 Opened 1 year ago Closed 1 year ago

Use TabDialogBox for print UI

Categories

(Toolkit :: Printing, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020_v81])

Attachments

(1 file, 2 obsolete files)

When the TabDialogBox is ready we should move our dialog to use it since it handles some cases we haven't dealt with and will reuse that code rather than writing our own.

Blocks: 133787
No longer depends on: 133787, 1649202
Whiteboard: [print2020_v80] → [print2020_v81]
Blocks: 1658165
Assignee: nobody → mstriemer
Status: NEW → ASSIGNED
Duplicate of this bug: 1659085
Duplicate of this bug: 1657506
Duplicate of this bug: 1658165
Duplicate of this bug: 1658247
Duplicate of this bug: 1657508
Attachment #9169235 - Attachment description: Bug 1653317 - Use TabDialogBox for tab modal print UI → Bug 1653317 - Part 1: Use TabDialogBox for tab modal print UI

The initial focus sometimes failed because print.html was not fully initialized.
Setting mozSubdialogReady makes SubDialog wait for the async init to ensure
the focus call succeeds.

Attachment #9170683 - Attachment description: Bug 1653317 - Fixed initial focus and ESC hotkey on print preview. r=mstriemer → Bug 1653317 - Fixed initial focus and ESC hotkey on print UI. r=mstriemer
Blocks: 1657994
Blocks: 1658445
Blocks: 1660026
Attachment #9169235 - Attachment description: Bug 1653317 - Part 1: Use TabDialogBox for tab modal print UI → Bug 1653317 - Use TabDialogBox for tab modal print UI

Comment on attachment 9170533 [details]
Bug 1653317 - Part 2: Move print preview updating code into print.js

Revision D87366 was moved to bug 1660026. Setting attachment 9170533 [details] to obsolete.

Attachment #9170533 - Attachment is obsolete: true
Attachment #9170683 - Attachment is obsolete: true
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e38ea8c830c
Use TabDialogBox for tab modal print UI r=Gijs,pbz
See Also: → 1660110
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.