Open Bug 165826 Opened 17 years ago Updated 6 months ago

Keyboard layout changes randomly

Categories

(Core :: User events and focus handling, defect)

x86
Windows 2000
defect
Not set

Tracking

()

People

(Reporter: jns, Unassigned)

References

Details

(Keywords: intl)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Sometimes, all of a sudden mozilla starts acting as if I used a US keyboard,
only going back to \normal\ again after restarting mozilla.
*Sorry, can\t explain better, and sorry if this looks ugly. Not used to using
the keyboard this way, not sure about which keys to press when.. uurgh.(

Reproducible: Always

Steps to Reproduce:
1. No idea.
What type of keyboard are you using right now?

Also, Mozilla 1.0 is a bit old to report bugs against right now. Try a newer
version available at the mozilla.org page.

and are you shifting from another language set in Win2k? Some languages shift
into a different input method by pressing the left-shift-button.
Jens Sahlin:  have you resolved this problem?  I am marking this bug WORKSFORME
because you have not commented back on this bug; however, if you still
experience this problem using a new version of mozilla such as 1.0.1 or 1.2b,
please re-open this bug.  Thank you!
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
I can confirm experiencing the same problem, using Moz1.3, build ID 2003011308
on Win2k. Language shifting in Win2k is disabled on my computer. I can't tell
exactly what are the steps to reproduce this bug, only thing I'm sure is that it
happens when I switch from one computer to the other on my keyboard-mouse-screen
switch by using its keyboard shortcuts: Ctrl+Alt+Tab or Ctrl+Alt+1. I think the
problem is only related to Mozilla, as all my other apps running are unaffected
by this keyboard layout problem (hence, the cause is not my switch).

If I find a definitve way to reproduce this bug, I'll add a new comment.
-> REOPEN

Zeiram: what type keyboard are you using?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
My default keyboard layout is Swiss French (I suppose that's what you meant by
"type") (which also means that the bug might be triggered without my realising
it as the only main characters changed between this layout and the US layout are
'y' and 'z'). OS is win2k professional in English.

One thing I forgot to mention previously is that the input changes for Mozilla
are for the whole application: URL bar, textareas in pages, mail compose window, ...
-> added keyword 'intl'
-> Browser/Event Handling (the description 'Any strangeness with keyboard
typing, mouse actions, focus changes.' fits)

-> NEW [reporter + duplicator]
-> summary changed from 'sometimes changes how to read input from keyboard'
Assignee: asa → saari
Status: UNCONFIRMED → NEW
Component: Browser-General → Event Handling
Ever confirmed: true
Keywords: intl
QA Contact: asa → trix
Summary: sometimes changes how to read input from keyboard → Keyboard layout changes randomly
OK, it was my fault. I thought I had completely disabled language shifting in
Win2k, but it turns out this wasn't the case. All my problems were only due to
Win2k, not Mozilla. For me, this bug can now be marked again as WORKSFORME. 

Sorry for all the trouble.
I have a similar problem with 1.3 & Win XP, but it generally only seems to
happen to me while I am reading newsgroups. Suddenly I will find when I go to
hit the "mark all read" key combo that it doesn't work. Then if I open up a
composition window I see that all my keys are showing wrong letters. Restarting
Mozilla fixes it temporarily. I still haven't been able to pin down exactly what
causes it, sorry.
I can change keyboard-layout with Shift+Alt - this is a feature I guess. Is this
your problem?
*** Bug 287831 has been marked as a duplicate of this bug. ***
Assignee: saari → nobody
QA Contact: trix → events
The behavior for Internet Explorer 8 on Windows Vista and Windows 7, which should also happen for Firefox on these platforms, is to remember a non-default keyboard layout only for the current tab.  All other tabs retain the default keyboard layout.  The tab in which the layout was changed retains this layout.

Firefox 4 on Windows 7 continues to have inconsistent behavior when multiple keyboard layouts are used.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.