Closed Bug 1658405 Opened 1 year ago Closed 1 year ago

Print sheet in narrowest possible Firefox window is cut off

Categories

(Toolkit :: Printing, defect, P1)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox81 --- fixed

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, Whiteboard: [fixed by bug 1654962])

Attachments

(2 files)

Steps to reproduce:

  1. Resize Firefox window to be as narrow as possible
  2. Open any page
  3. Do command-p

What happens:

I see a print preview with no UI to change options or even to dismiss the dialog.

Expected result:

Sheet should extend outside of original window to provide sheet with complete UI like Safari.

Actual result and desired result can be seen - Safari is on the right in the attached screenshot.

Blocks: 133787

I don't know if we can do this, but we should really try…

Whiteboard: [print2020_v81]
Attached image image.png

I have WIP on the resize patch to support the narrowest window size (but smallest vertically is still unusable since it's so small)

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1654962
Severity: -- → S2
Priority: -- → P1
Status: RESOLVED → REOPENED
Depends on: 1654962
Resolution: DUPLICATE → ---

(This should be fixed by bug 1654962 so removing the [print2020_v81] whiteboard tag for easier tracking.)

Whiteboard: [print2020_v81]

Asif, can you confirm this is fixed for you now?

Flags: needinfo?(yoasif)

Yep, it looks fine to me now, thanks!

Flags: needinfo?(yoasif)

Thanks!

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1654962]
You need to log in before you can comment on or make changes to this bug.