Closed Bug 1658409 Opened 1 year ago Closed 1 year ago

Print button is sensitive to user input and presents an error clicking print when no printer is selected

Categories

(Toolkit :: Printing, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox81 --- fixed

People

(Reporter: yoasif, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, Whiteboard: [print2020_v81])

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:

  1. Ensure no printer is set up
  2. Do command-p
  3. Click Print

What happens:

Error appears with "Some printing functionality is not currently available."

Expected result:

Print button should not be active unless a valid printer is selected. This may be worked around by providing a save to pdf option instead (Edge does this).

Blocks: 133787
Whiteboard: [print2020_v81]
Severity: -- → S4
Priority: -- → P3
Assignee: nobody → emalysz
Status: NEW → ASSIGNED

I plan on handling this in my patch for Bug 1656057

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1656057
Attachment #9169317 - Attachment is obsolete: true
Status: RESOLVED → REOPENED
Depends on: 1656057
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED

The fix was covered in Bug 1656057

Status: ASSIGNED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.