Closed Bug 1658923 Opened 2 years ago Closed 1 year ago

Difficult to see calendar event reminder details / location as it takes on similar color to background

Categories

(Calendar :: Alarms, defect)

Thunderbird 80
defect

Tracking

(thunderbird_esr78 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed

People

(Reporter: thee.chicago.wolf, Assigned: Paenglab)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.57

Steps to reproduce:

I'm testing 80.0b3 and an event I had schedule for this morning fired off the reminder window.

Actual results:

The Title and Date are clearly visible but the "Details..." and Location info are nearly the same color as the background and thus nearly impossible to see. Would be good to have the font match what's being show in the event title and date. In this case, that font is white whereas the other details and location font is blue.

Expected results:

The "Details..." font and Location info font should be visible.

Also, I'd like to mention that when one does click on the "Details..." link to open the "Edit Event" window, the Reminder widow fonts all appear more visble (see second image). Not sure where it's pulling that blue background from in the first image (or blue link color in the second image), but maybe it would be best to have it all simply be black and white as it appears the second image for the sake of visibility? Just my 2 cents.

I can confirm the links are difficult to see using Thunderbird's Default and Light themes on 80.0b3 on Ubuntu 18.04.4 LTS.

Fine using the Dark theme.

Component: Untriaged → Alarms
OS: Unspecified → All
Product: Thunderbird → Calendar
Hardware: Unspecified → All
Version: 80 → Thunderbird 80

This makes that the alarm-details-label always inherits the richlistitem colour.
I also set a text-shadow: none; on the richlist to stop the text-shadow with LW-themes.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9170009 - Flags: review?(paul)
Comment on attachment 9170009 [details] [diff] [review]
1658923-reminder-details-color.patch

Review of attachment 9170009 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Attachment #9170009 - Flags: review?(paul) → review+
Target Milestone: --- → 81 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5d3ca71dc7b5
Inherit the color of the alarm-details-label to make it always readable. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9170009 [details] [diff] [review]
1658923-reminder-details-color.patch

[Approval Request Comment]
Regression caused by (bug #): bug 1657607
User impact if declined: almost unreadable details link
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9170009 - Flags: approval-comm-esr78?
Attachment #9170009 - Flags: approval-comm-beta?

Comment on attachment 9170009 [details] [diff] [review]
1658923-reminder-details-color.patch

already on beta

Attachment #9170009 - Flags: approval-comm-beta?

Comment on attachment 9170009 [details] [diff] [review]
1658923-reminder-details-color.patch

[Triage Comment]
Approved for esr78

Attachment #9170009 - Flags: approval-comm-esr78? → approval-comm-esr78+
Duplicate of this bug: 1662801
You need to log in before you can comment on or make changes to this bug.