Closed Bug 1659282 Opened 2 years ago Closed 2 years ago

Switching to Dark TB theme and back to the Default is not working properly

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(thunderbird_esr78+ fixed, thunderbird80 wontfix, thunderbird81 wontfix, thunderbird82 affected)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird80 --- wontfix
thunderbird81 --- wontfix
thunderbird82 --- affected

People

(Reporter: walts48, Assigned: aleca)

References

Details

(Whiteboard: smoketestbeta)

Attachments

(3 files)

Attached image aom-tab.png

While testing the 80.0b4 release candidate with a new profile on Ubuntu 18.04.4 LTS with the default Adwaita theme.

What I did:

Created an email account.
Opened Add-ons Manager.
Changed to the Dark TB theme.
Checked the Mail tab and it looked fine.
Selected the Default theme to switch back and continue testing.

What Happened:

The AOM Tab remained Dark.
The Mail tab switched back to Default theme.
The Folder pane icons disappear and so do messages in the Thread pane.

What Should Happen:

The AOM tab should return to the Default theme.
The Mail Tab should return to the Default theme and show the Folder and Thread panes as expected.

Attached image mail-tab.png

Mail tab screenshot.

Blocks: 1659284
Summary: Switching to Dark TB theme and back to the Default is not working properly → Switching to Dark TB theme and back to the Default is not working properly on Ubuntu Linux

This is a known issue, see bug 1659282 comment 17 and ff.

OS: Linux → All
Hardware: x86_64 → All
Summary: Switching to Dark TB theme and back to the Default is not working properly on Ubuntu Linux → Switching to Dark TB theme and back to the Default is not working properly
Duplicate of this bug: 1659284

(In reply to Richard Marti (:Paenglab) from comment #2)

This is a known issue, see bug 1659282 comment 17 and ff.

Sorry, I don't see a comment 17 in this bug report.

Did you mean some other report?

Flags: needinfo?(richard.marti)

Sorry, wrong bug. Correct bug 1638233 comment 17 ff.

Flags: needinfo?(richard.marti)

[Don't think this ever worked]

No longer blocks: 1659284

I have the same issue or a related bug, so I will report it.

OS: Windows 10 Pro Ver.1909

Steps to reproduce:

  1. Open Windows Settings > Personalization > Colors.
  2. Set "Choose your color" to "Light" or "Dark".
  3. Launch Thunderbird with new profile.
  4. Switch "Choose your color" in Windows Settings.
  5. Open Thunderbird Config Editor and check "ui.systemUsesDarkTheme".

Actual results:

(case-1) TB78.2.0, 81.0b1, 82.0a1(2020-08-26)
Thunderbird Default theme will be "Light" or "Dark" according to the Windows color setting when launching with the new profile.
However, that setting is fixed, and it does not automatically follow the change of the Windows color setting.
"ui.systemUsesDarkTheme" can be changed from 0 to 1, but cannot be changed from 1.
Probably the fix for bug 1638233 is involved.

(case-2) TB82.0a1(2020-08-27)
Thunderbird Default theme is switch to "Light" regardless of Windows color settings.
Probably the fix for bug 1661229 is involved.

Expected results:
Thunderbird Default theme will automatically follow the change of the Windows color setting.

(In reply to EarlgreyTea from comment #8)
The issues you reported are related to bug 1661229, not this bug which is tackling a different issue.

No longer blocks: tb68found
Assignee: nobody → alessandro

This seems to fix it for me, but I'm not sure as it seems too simple.
I'm worried we might create regressions for system dark themes on Windows.

Attachment #9177031 - Flags: review?(richard.marti)
Status: NEW → ASSIGNED

Comment on attachment 9177031 [details] [diff] [review]
1659282-dark-default-theme.diff

r+ when it works for you.

I see no difference on Windows:

  • dark system theme
  • start TB with default theme, content pages are dark
  • enable TB dark theme, content pages still dark
  • disable dark theme, content pages change to light
  • restart TB, content pages are again dark

The same happens with and without your patch.

Attachment #9177031 - Flags: review?(richard.marti) → review+

This patch takes care of this scenario for me:

  • System default theme
  • Change TB to dark theme, everything looks good
  • Change to TB Default theme (by clicking on Default and not Disable on the dark theme)
  • The Account Central and Message Pane are still dark until a restart

The patch fixes it.
Can you recreate this scenario?

Yes, this fixes the Account Central colouring. No matter if I disable the dark theme or enable the default theme. Both should be the same.

Target Milestone: --- → 83 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d6f834c37fc2
Fix UI inconsistencies when switching from Dark theme to Default. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Comment on attachment 9177031 [details] [diff] [review]
1659282-dark-default-theme.diff

We missed this during the recent 78 uplift.

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Wrong icons and text color when switching between dark and light theme
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): very low

Attachment #9177031 - Flags: approval-comm-esr78?

Comment on attachment 9177031 [details] [diff] [review]
1659282-dark-default-theme.diff

[Triage Comment]
As discussed in Matrix, approved by wsmwk.

Attachment #9177031 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.