Closed Bug 1659389 Opened 1 year ago Closed 1 year ago

[macOS] Print modal options fail to be displayed intermittently

Categories

(Toolkit :: Printing, defect)

Firefox 81
Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- verified

People

(Reporter: vlucaci, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Affected versions

  • 81.0a1(20200816214203)

Affected platforms

  • macOS 10.15.6

Steps to reproduce

  1. Launch FF with a clean profile
  2. Trigger the new Print modal.

Expected result

  • The new print preview modal is displayed with all the installed printers available to use and all options available.

Actual result

  • The new print preview modal is displayed with all the options missing from the modal intermittently.

Suggested Severity

  • Seeing as how this is a regression from 1656062, occurs intermittently and affects only one OS, I would consider this an S2.

  • Potential regressor: 1656062

Additional notes

Is this the same bug as printers not showing up intermittently?

The UI is now hidden until we find the printers, so sounds like they're probably related.

Hi Vlad, I believe this is fixed in tonight's nightly… Could you re-test it and see if all the printers show up (after the loading screen finishes)?

(Also, I'm removing the [print2020_v81] tag, because this should be fixed by a different bug, and it's making it hard for me to track…)

Flags: needinfo?(vlad.lucaci)
Whiteboard: [print2020_v81]
Has STR: --- → yes
Flags: needinfo?(vlad.lucaci) → needinfo?(anca.soncutean)

(In reply to Blake Winton (:bwinton) (:☕️) from comment #4)

Hi Vlad, I believe this is fixed in tonight's nightly… Could you re-test it and see if all the printers show up (after the loading screen finishes)?

  • I can't reproduce this issue with the latest builds, verified with Fx 82.0a1 (2020-08-25) and Fx 81.0b2 on macOS 10.15.
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(anca.soncutean)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.