Closed Bug 1659413 Opened 1 year ago Closed 1 year ago

Directly loaded GIF images intermittently fail to display in Preview when toggling between Portrait and Landscape

Categories

(Core :: Print Preview, defect, P2)

Firefox 81
Desktop
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox81 --- affected
firefox82 --- ?

People

(Reporter: vlucaci, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v81] )

Attachments

(1 file)

Affected versions

  • 81.0a1(20200816214203)

Affected platforms

  • 81.0a1(20200816214203)

Steps to reproduce

  1. Launch FF.
  2. Open a GIF image (eg: https://upload.wikimedia.org/wikipedia/commons/2/2c/Rotating_earth_%28large%29.gif )
  3. Trigger the new Printing UI modal.
  4. Toggle between Portrait and Landscape.

Expected result

  • The GIF preview is displayed without any issues, regardless of page orientation.

Actual result

  • Toggling between Landscape and Portrait orientation renders the GIF preview to fail to be displayed.

Suggested Severity

  • Seeing as how it only affects a specific file format, I would consider this issue an S3.

Regression range

  • Not a regression.

Additional notes

Seems like a Core::Print Preview bug…

Component: Printing → Print Preview
Product: Toolkit → Core

Does this happen in the old print preview too? If so, I don't think this blocks bug 133787 or needs to be marked as [print2020_v81].

Flags: needinfo?(vlad.lucaci)

(Unless we broke this since we started work on the new UI, but you say this isn't a regression.)

I've been trying to reproduce this on macOS without any luck.

Severity: -- → S3
Priority: -- → P2
Summary: GIF images are not displayed in Preview when toggling between Portrait and Landscape → Directly loaded GIF images intermittently fail to display in Preview when toggling between Portrait and Landscape

We have tried several times to reproduce this issue on different machines (including the one that Vlad encountered this issue) & on multiple OS's (Windows 10, Ubuntu 20.04, macOS 10.14 & macOS 10.15) but we failed to do so.

Since Vlad is in PTO and since we couldn't reproduce this, I'm marking this as WORKSFORME for now and maybe we could get a confirmation from him when he returns (leaving the ni?).

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Hello,

I tried reproducing this issue on macOS 10.15, macOS 10.14 , Ubuntu 20.04 and Win10x64 with 82.0a1(20200830213209) , 81.0b4(20200829200810) and did not manage to reproduce this anymore.

Flags: needinfo?(vlad.lucaci)
Attached image screencast issue.gif

This issue is still present intermittently. At this point, we were able to reproduced it again on Ubuntu 18 and macOS 10.14, but only on Beta (81.0b5).

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Hopefully a bunch of changes relevant with bug 1636728 fixes this.

Anca, can you please re-check it on the next 81.0b6? Thanks!

Flags: needinfo?(anca.soncutean)

This looks fixed with Fx 82.0a1 (2020-09-06) and Fx 81.0b7 on Windows 10, Ubuntu 18.04 and macOS 10.14.

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Flags: needinfo?(anca.soncutean)
Resolution: --- → WORKSFORME

Thank you Anca!

You need to log in before you can comment on or make changes to this bug.