Closed Bug 1679392 Opened 2 years ago Closed 2 months ago

GIF file fails to render sometimes while changing orientation or scale settings

Categories

(Core :: Print Preview, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1659413
Tracking Status
firefox84 --- affected
firefox85 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020][old-ui+])

Affected versions

  • Firefox 84.0b4
  • Firefox 85.0a1

Affected platforms

  • macOS 11.1
  • Windows 10
  • Ubuntu 20.04

Steps to reproduce

  1. Launch Firefox
  2. Load this GIF page
  3. Print preview the page and play with Orientation and Scale settings

Expected result

  • The GIF is rendered

Actual result

  • Sometimes, the GIF fails to render

Regression range

Additional notes

  • The issue can be seen in the following attachment

Suggested severity

  • S3
Has STR: --- → yes

:csasca, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Severity: -- → S4
Priority: -- → P4
Whiteboard: [print2020_v85][old-ui+] → [print2020_v89][old-ui+]
Whiteboard: [print2020_v89][old-ui+] → [print2020][old-ui+]

Catalin, can you still reproduce this? (I can't, but I'm not sure I have the right setup.)

Also: if you can reproduce, maybe we should dupe this to bug 1659413 and reopen that bug? The two bugs have the same STR/symptoms as far as I can tell.

(It looks like bug 1659413 was closed in September 2020 as WORKSFORME because we thought it wasn't reproducible anymore (bug 1659413 comment 8 - 9), and then Catalin was able to reproduce 2 months later in November 2020 and filed this bug as a result instead of reopening the original bug. I think a new bug [this one] would make sense if we really think it was fixed and then broke again, but it's not clear to me that it really was fixed; it seems like maybe it was just difficult/rare-to-reproduce.)

Flags: needinfo?(catalin.sasca)

Seems that it is not reproducible anymore either on my side. Tried on 103.0 and playing with the settings worked fine.

Flags: needinfo?(catalin.sasca)

Thanks! I'm going to dupe this to bug 1659413 then, and I'll add a note over there to indicate that we reproduced it after that bug was closed but think it's WFM at this point.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1659413
You need to log in before you can comment on or make changes to this bug.