If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cursor position in edit boxes isn't reported to magnify.exe

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: timeless, Assigned: Aaron Leventhal)

Tracking

({access})

Trunk
x86
Windows 2000
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020830
This applies to both single line edit boxes and multiline textareas.

run magnify.exe
magnification level: [2 |]
[x] follow text editing

file a bug and type more than 6 characters for the subject or more than 3 lines
for the description.

expected results: as you type the magnifier should follow your cursor.

you can compare ie, notepad, a run dialog or any normal thing.
(Reporter)

Updated

15 years ago
Blocks: 82207

Comment 1

15 years ago
The penalty we pay for not using native widgets.

Comment 2

14 years ago
*** Bug 211017 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Assignee: jag → aaronleventhal
Keywords: access
(Assignee)

Comment 3

14 years ago
Actually we do report this via MSAA's
ROLE_SYSTEM_CARET/OBJID_CARET/EVENT_LOCATIONCHANGE. It's just that magnify.exe
doesn't actually use MSAA for the caret -- they assume native widget interfaces.
Like Jag said, it's the penalty we pay for not using native widget.

Anyway, this is WORKSFORME because we do report the cursor position. It's just
that Magnify.exe doesn't use it.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.