Magnify Window Does Not Follow Text as You Type

VERIFIED DUPLICATE of bug 165992

Status

VERIFIED DUPLICATE of bug 165992
16 years ago
10 years ago

People

(Reporter: slimebug, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Avant Browser [avantbrowser.com]; i-MailBook; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: 

i've seen this problem in many editors, so i went to the microsoft knowledge 
base. i found a summary and article number that only needs the word 'may' 
changed to 'does' for it to be a perfect description of the problem i'm having 
when composing mail. i couldn't access the full article so i don't know if 
this will be helpfull to you or not. but i'm trying. this problem is in 
mozilla, netscape, and thunderbird. but, this bugzilla editor works correctly 
with the magnify window.  this is what i found at microsoft.   "Magnify Window 
May Not Follow Text as You Type 
 (153366) - When you are using the IntelliPoint software version 1.1 with 
Microsoft Windows 95 or Microsoft Windows 98, the Magnify window may not 
follow the text as you type in a document."  yes, i know it doesn't mention  
anything about xp. but that could be caused if the article was written several 
years ago.         

Reproducible: Always

Steps to Reproduce:
1. use START > ALL PROGRAMS > ACCESSORIES > ACCESSIBILITY > MAGNIFIER  to open 
the magnifier window. 
2. double click the magnifier settings button on the task bar to open the 
options window unless it's already open. ensure the 'follow text editing' 
and 'show magnifier' boxes are ticked, then minimize the options window.
3. open the mozilla compose mail window.
4. move the mouse pointer off the screen.
5. while observing the contents of the magnifier window, hold any letter key 
down such that it makes a stream of characters all the way across the screen.
6. close mozilla, open notepad, and do steps 4 and 5 again.
7. note the difference between the first and second executions of the steps.
Actual Results:  
i see nothing in the magnifier window on the first execution of steps 4 and 5. 
on the second execution, i see the characters in the magnifier window. they 
move in the magnifier window while characters are being typed in the first and 
last quarters of the editor line. they appear to remain stationary in the 
middle of the magnifier window while the characters being typed are in the 
second and third quarters of the editor line.

Expected Results:  
this problem involves interaction with a non mozilla product.  mozilla did 
nothing wrong, nor did netscape, nor thunderbird.  however, because the 
interacting product is from the company that is pretty much the standard 
regardless of whether it deserves to be, well, i think you understand.  though 
i have been a user of gecko products for many years, my failing eyesight has 
made me depedent on the magnifier window. i must find another email client 
until this problem is resolved. i hope this helps.  

i don't know how to answer the severity question.  it's user dependent and 
means nothing to the majority who don't use the magnifier. but to someone who 
is visually challenged and knows about and depends on the magnifier, it's a 
stopper. also, it affects mozilla, netscape, and thunderbird mail composers. 
perhaps most bugs do. i'm just going to leave the severity question unanswered 
and let you decide where you want it to fit in the scheme of things. last, i 
won't write bug reports to thunderbird and netscape. you know best where the 
resources live to handle this problem. hence, i'll trust the problem will go 
to where it can best be resolved, and everyone will share in the 
resolution.
(Reporter)

Comment 1

16 years ago
this sentence, located in my last paragraph, 'perhaps most bugs do' should 
read 'perhaps many individual bugs affect the similar products of mozilla, 
netscape, and thunderbird.'
Summary: Magnify Window Does Not Follow Text as You Type → Magnify Window Does Not Follow Text as You Type

Comment 2

16 years ago
There are several bugs about the interaction between Mozilla and Magnifier :
bug 165992, bug 165994, bug 165995, bug 165996, bug 165998, bug 166000, bug
166004, ... all blockers for bug 82207 (MSAA XUL support).

The reason is that Mozilla isn't using native widgets (textfields, dialog
bloxes, menus, etc...) and that's why Magnify can't cooperate with Mozilla. It
doesn't even know where the cursor is (bug 165992). It's no wonder that Magnify
has so much trouble with a lot of applications out there (not just Mozilla).
This is also why real accessability software is so hard to do. Following the
cursor is just the beginning ...

PS : fixing the interaction between Moz and MSAA is one thing ... but we also
have to do it multi-platform !

*** This bug has been marked as a duplicate of 165992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.