Closed Bug 1661722 Opened 1 year ago Closed 1 year ago

Ensure that the selected color mode when disabled matches what is shown in the print preview

Categories

(Toolkit :: Printing, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1661645
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- fixed

People

(Reporter: emmamalysz, Unassigned)

References

(Regression)

Details

(Whiteboard: [print2020_v81])

Attachments

(1 file)

If a mac user previously had "black and white" mode configured for a color printer, the update from Bug 1660857 will put them in a weird state.
The color mode option will be selected to color (expected) and disabled (expected), but the preview will show their last saved color setting, which was black and white.

Yes! I just encountered and was about to file this...It seems that the print preview is not updating after changing from a destination that has color x to another destination that supports only color y (physical printers that supports only B&W printing and Save to PDF (which now supports only color mode printing)).

This sounds like it's going to be fixed in bug 1661645

Severity: -- → S3
Priority: -- → P1
Component: Print Preview → Printing
Product: Core → Toolkit
Depends on: 1661645
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1661645

Duping this because https://bugzilla.mozilla.org/show_bug.cgi?id=1661645#c1 already addressed the problem, and the patch up in that bug covers this case.

You need to log in before you can comment on or make changes to this bug.