Closed Bug 1662225 Opened 1 year ago Closed 1 year ago

With "Save to PDF" selected as destination in the tab-modal UI, impossible to print via the System UI

Categories

(Core :: Printing: Setup, defect, P1)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1661374

People

(Reporter: jfkthame, Unassigned)

Details

(Whiteboard: [print2020_v81])

STR:

  • Open the new (tab-modal) print UI
  • Select "Save to PDF" as the Destination
  • Click the button to open the native dialog
  • Attempt to print to a physical printer from the native UI

ER:
Job is printed to the printer selected in the native UI

AR:
Nothing appears to happen. Actually, the job goes to a file "mozilla.pdf".

Priority: -- → P1
Whiteboard: [print2020_v81]

(Aaah! Sorry about that, I thought that was a front-end bug. Feel free to re-prioritize…)

Ah - this may be a front-end bug: I see that on both Windows and Linux, when I choose Save to PDF as the destination, the option to "Print using the system dialog" is hidden. But on macOS, it remains available. Is that intended?

If the option were made unavailable (like on the other platforms), that would resolve this issue. But if it's supposed to still be there, then we have a (platform-level?) bug in that it doesn't actually work.

Looks like bug 1661374 may have addressed this; I will re-test and see if this can be closed.

WFM using a new local build that includes bug 1661374.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1661374
You need to log in before you can comment on or make changes to this bug.