Closed Bug 1662360 Opened 1 year ago Closed 1 year ago

[macOS] Print modal takes long to launch

Categories

(Toolkit :: Printing, defect)

Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1661157
Tracking Status
firefox82 --- fixed

People

(Reporter: vlucaci, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [print2020_v81] [old-ui-])

Attachments

(1 file)

Affected versions

  • 81.0b4
  • 82.0a1

Affected platforms

  • macOS 10.15.6

Steps to reproduce

  1. Launch FF.
  2. Trigger the Print UI modal.

Expected result

  • Print UI modal is displayed instantly and the user can interact with it.

Actual result

  • Print UI modal takes to around 60-90 seconds to load.

Suggested Severity

  • Seeing as how it this issue may only be related to my devices in some way, but however does affect my testing, I would consider this an S3.

Regression range

Additional notes

Has Regression Range: --- → yes
Has STR: --- → yes

Vlad, can you please narrow down the regression range? Thanks!

See Also: → 1661157

Vlad ^?

Flags: needinfo?(vlad.lucaci)

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b0888d07df690ed43df31a2b013d12464b183a30&tochange=920ef04bf423ccb2ce154ab6ff3e2aaa47f5b2e3

I suspect the culprit is Bug 1653317 - Use TabDialogBox for tab modal print UI

However:

Backed out 2 changesets (bug 1656220, bug 1656219) for browser-chrome failures at browser_UsageTelemetry_urlbar.js and browser_oneOffs.js on a CLOSED TREE

Backed out changeset bf68aec38a05 (bug 1656220)
Backed out changeset 706d2900077b (bug 1656219)

2020-09-01T14:44:40.171000: DEBUG : Did not find a branch, checking all integration branches
2020-09-01T14:44:40.173000: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=920ef04bf423ccb2ce154ab6ff3e2aaa47f5b2e3&full=1
2020-09-01T14:44:40.757000: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=920ef04bf423ccb2ce154ab6ff3e2aaa47f5b2e3&full=1
2020-09-01T14:44:41.162000: DEBUG : Didn't find 920ef04bf423ccb2ce154ab6ff3e2aaa47f5b2e3 in mozilla-inbound
2020-09-01T14:44:41.162000: DEBUG : Repo 'autoland' seems to have the earliest push
2020-09-01T14:44:41.163000: INFO : ************* Switching to autoland by process of elimination (no branch detected in commit message)

Flags: needinfo?(vlad.lucaci)

This seems like it should be partially fixed by bug 1661361 (which landed on mozilla-central about three hours ago)…
And if not, we're doing more investigation in bug 1661157, so I think we should dupe this to that one.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1661157

I can confirm that the issue is not present on macOS 10.14 with the latest 81.0b5. However I am still able to reproduce it on macOS 10.15 on the same device (new profiles)

Flags: needinfo?(bwinton)

Bug 1661361 hasn't been uplifted yet, but it's interesting that you see it on 10.15 and not 10.14…
Please leave that (and any further investigation you do) as a comment on bug 1661157, since it seems like it could be helpful, if not in diagnosing the problem, then in figuring out what platforms to concentrate on!

Flags: needinfo?(bwinton)
You need to log in before you can comment on or make changes to this bug.