Closed Bug 1662858 Opened 6 months ago Closed 1 month ago

Implement JS API for FOG

Categories

(Toolkit :: Telemetry, task, P3)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: chutten, Unassigned)

References

Details

(Whiteboard: [telemetry:fog:m6])

As designed in bug 1635238 and atop the MLA defined in bug 1646165 (and probably on top of the C++ API of bug 1642646), we're gonna need a JS API.

This covers:

  • Generating the specific metrics APIs for all current metric types
    • probably via a custom outputter on glean_parser like we did for the first pass at the Rust API in bug 1635260
  • Supporting multiple processes
    • Likely get this "for free" because the underlying Rust API supports IPC (or will later)
  • Tests
    • A regression suite for the custom glean_parser outputter
    • unit tests (xpcshell?) for using generated APIs to record data and test values
  • Docs
    • In-tree API docs with examples would be nice, but this can be taken as a follow-up
Depends on: 1673610
Depends on: 1673642
Depends on: 1673643
Depends on: 1673644
Depends on: 1673648
Depends on: 1673660
Depends on: 1673661
Depends on: 1673662
Depends on: 1673663
Depends on: 1673664
Depends on: 1680020
Depends on: 1675277
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.