Closed Bug 1663134 Opened 1 year ago Closed 1 year ago

Crash in [@ xul.dll | nss3.dll | mozglue.dll | xul.dll | mozglue.dll | xul.dll | mozglue.dll | xul.dll | mozglue.dll | xul.dll | mozglue.dll | xul.dll | nss3.dll | xul.dll | RtlAcquireSRWLockExclusive]

Categories

(Core :: Printing: Setup, defect)

Firefox 81
Unspecified
Windows 10
defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- verified
firefox82 --- verified

People

(Reporter: emilghitta, Assigned: hiro)

References

Details

(Keywords: crash, Whiteboard: [print2020_v81] [old-ui-] [Fixed by 1663053])

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/86b1dbbb-dfaf-4167-9340-99ea70200904

Top 10 frames of crashing thread:

0 xul.dll xul.dll@0x2024e8 
1 xul.dll xul.dll@0x17ccbc5 
2 xul.dll xul.dll@0x9930 
3 xul.dll xul.dll@0x21155a9 
4 xul.dll xul.dll@0x1337b4 
5 nss3.dll nss3.dll@0xff948 
6 mozglue.dll mozglue.dll@0xb1ae 
7 xul.dll xul.dll@0x28314f 
8 xul.dll xul.dll@0x4ffb0cf 
9 xul.dll xul.dll@0x22ea 

I think that the fix for Bug 1663053 may also fix this crash

Do we know if this happens in both the new and old UI, or just the new UI?

Component: Printing → Printing: Setup
Product: Toolkit → Core
Whiteboard: [print2020_v81]

Encountered this only on the new UI.

The steps are the same as for Bug 1663131. Will update this description shortly

Flags: needinfo?(emil.ghitta)
Whiteboard: [print2020_v81] → [print2020_v81] [old-ui-]

This is not reproducible using Firefox 82.0a1 (BuildId:20200904094341) since the fix for Bug 1663053 has landed.

Leaving a ni? on myself as a reminder to verify this once Bug 1663053 lands in beta.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: [print2020_v81] [old-ui-] → [print2020_v81] [old-ui-] [Fixed by 1663053]
Assignee: nobody → hikezoe.birchill
Depends on: 1663053
Target Milestone: --- → 82 Branch

This issue is verified fixed using Firefox 81.0b7 (BuildId:20200906164749) on Windows 10 64bit

Status: RESOLVED → VERIFIED
Flags: needinfo?(emil.ghitta)
You need to log in before you can comment on or make changes to this bug.