Closed Bug 1663164 Opened 9 months ago Closed 9 months ago

TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar_searchmode.js | Test timed out when Gecko 82 merges to Beta on 2020-09-21

Categories

(Toolkit :: Telemetry, defect)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 - fixed

People

(Reporter: NarcisB, Unassigned)

References

(Regression)

Details

(Keywords: regression)

[Tracking Requested - why for this release]:

Central as Beta simulation

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&selectedTaskRun=Kn2wRnNKTAOFv_Q-bB8x3A.0&resultStatus=testfailed%2Cbusted%2Cusercancel%2Crunnable&revision=9441959dd88c76430db843a9a57603a61c88d52e&searchStr=linux%2C18.04%2Cx64%2Cdebug%2Cmochitests%2Ctest-linux1804-64%2Fdebug-mochitest-browser-chrome-e10s%2Cbc12

Log link:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=314866022&repo=try&lineNumber=15968

Log snippet:
[task 2020-09-04T12:03:27.311Z] 12:03:27 INFO - TEST-PASS | browser/modules/test/browser/browser_UsageTelemetry_urlbar_searchmode.js | Found one-off button for search mode - {"engine":{"_name":"MozSearch","_shortName":"MozSearch","_loadPath":"[other]addEngineWithDetails:MozSearch@test.engine","description":"undefined","__searchForm":"http://example.com","_iconURL":"","_metaData":{"order":1,"loadPathHash":"iqoEkHRIOmyBTBriilf8bgg1y9eNc95/9U3CEqjGezU="},"_urls":[{"params":[],"rels":[],"resultDomain":"example.com","template":"http://example.com/?q={searchTerms}"}],"_isAppProvided":false,"_orderHint":"undefined","_telemetryId":"undefined","_updateInterval":null,"_updateURL":null,"_iconUpdateURL":null,"_extensionID":"MozSearch@test.engine","_locale":"default","_definedAliases":["alias"],"_hasPreferredIcon":null,"queryCharset":"windows-1252"},"_inheritedElements":{".button-icon":{}},"initializedAttributeInheritance":true} == true -
[task 2020-09-04T12:03:27.312Z] 12:03:27 INFO - Awaiting for the urlbar panel to open
[task 2020-09-04T12:03:27.312Z] 12:03:27 INFO - Buffered messages finished
[task 2020-09-04T12:03:27.313Z] 12:03:27 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar_searchmode.js | Test timed out -
[task 2020-09-04T12:03:27.314Z] 12:03:27 INFO - GECKO(4835) | [Parent 4835, Main Thread] WARNING: Suboptimal indexes for the SQL statement 0x7f72e5c38550 (http://mzl.la/1FuID0j).: file /builds/worker/checkouts/gecko/storage/mozStoragePrivateHelpers.cpp, line 113
[task 2020-09-04T12:03:27.314Z] 12:03:27 INFO - GECKO(4835) | MEMORY STAT | vsize 3968MB | residentFast 464MB | heapAllocated 132MB
[task 2020-09-04T12:03:27.315Z] 12:03:27 INFO - TEST-OK | browser/modules/test/browser/browser_UsageTelemetry_urlbar_searchmode.js | took 90200ms
[task 2020-09-04T12:03:27.316Z] 12:03:27 INFO - Not taking screenshot here: see the one that was previously logged

Looks like a fallout from https://hg.mozilla.org/mozilla-central/rev/8c777bf670c9. Drew, please have a look over this. Thank you.

Flags: needinfo?(adw)
Regressed by: 1658964

This actually doesn't reproduce anymore in the latest beta-sims, 5th and 6th.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(adw)
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Probably from the backout of bug 1658964 to work around bug 1663016 in the simulation.

You need to log in before you can comment on or make changes to this bug.