[RFE] Right-click should let me open a table cell in new Window (to overcome bad web site designs)

VERIFIED WONTFIX

Status

SeaMonkey
General
--
enhancement
VERIFIED WONTFIX
16 years ago
14 years ago

People

(Reporter: manojd, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Today, I can right-click the page & in case it uses frames, I can open the
specific frame in a new window.

My intranet web master (many other sites, I believe) likes to use tables for
this purpose. Means the specific article I am interested in reading is in a
table cell. Means I must put up with a lot of irrelevant garbage on screen. Wish
I could right-click to open the contents of a table cell in a separate window.

Reproducible: Always

Steps to Reproduce:
1. See Details above.

Comment 1

16 years ago
*** Bug 166316 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
a bit like 'view selection source', but in a regular window (not a view-source) ?
(Reporter)

Comment 3

16 years ago
Sorry about duplicate submission. I actually had cancelled one - but it must
have been sent by then.

On comment#2: No, I don't mean View->PageSource. I mean a new window or tab.
Perhaps the right-click menu item could be overloaded for table cell & frame (or
any other appropriate portion of currently visible page).

Updated

16 years ago
Summary: Wish: Right-click should let me open a table cell in new Window (to overcome bad web site designs) → [RFE] Right-click should let me open a table cell in new Window (to overcome bad web site designs)

Comment 4

16 years ago
Just my $0.02 on this. Tables should not be used for presentational layouts,
which is exactly what is being done here. Also, this kind of functionality
breaks the normal usage of table cells for the vast majority of users. Suggest
that this is an evangelism problem, and not something that needs to be added to
mozilla. Possibly it could be done through a mozdev project, but remember, table
cells are not like frames in any way, and should not be forced to behave like
them. I would mark this as WONTFIX
(Reporter)

Comment 5

16 years ago
Well, Eclectric. Evengelism takes effect over a 5y time span. Till then we have
to put up with stupid & irritating pages! Here is a straight-forward fix that
decouples evengelism from the way web masters are used to designing stuff.

Comment 6

16 years ago
Ctrl+click the table cell, then use the "view selection" bookmarklet from
http://www.squarefree.com/bookmarklets/pagedata.html.  A "view only this table
cell" feature would only work on pages that use tables for layout and even then
unreliably, so that's wontfix, but including "Show Only This Selection" on the
selection context menu would be reasonable (see also bug 105580).
(Reporter)

Comment 7

16 years ago
Thanks Jesse. But I don't quite get it.

a) Ctrl-LeftClick on table cell in Mozilla. Nothing happens.
b) Ctrl-RightClick on table cell in Mozilla. Drop down menu appears, but its
View Selection shows the HTML source.

Can you give the details steps to use your workaound? Thank you.

Updated

16 years ago
Blocks: 105580

Comment 8

16 years ago
Details of the workaround:
1. Go to http://www.squarefree.com/bookmarklets/pagedata.html
2. Drag the green "view selection" link to your personal toolbar.
3. Select some text with the mouse, or Ctrl-click a table cell (in any page).
4. Click the "view selection" bookmarklet.

This should open just the selection in a new window.

Comment 9

16 years ago
REsolving since there is a workaround.

IMO, this is 3rd-party add-on territory anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 10

15 years ago
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.