[FEATURE] Enhanced context menu for selections

RESOLVED INVALID

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED INVALID
17 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: jag (Peter Annema))

Tracking

(Depends on: 3 bugs, Blocks: 2 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
This is a continuation of bug 15176.  The idea is that when a user right-clicks 
on a selection, they should be given a context menu that pertains to the 
selection rather than to the object directly under the mouse cursor.

Here are some ideas for commands that could be on the context menu for a 
selection.  Most of them are from bug 15176 and dups.

- copy
- copy as text (eg to paste into MS Word) (bug 67142)

- treat selected text as a link or e-mail address (bug 10080)
- open [number] selected links in new windows (bug 9274)

- view partial source (bug 49721)
- open selection as a new document (eg to print, save, or use a bookmarklet)

- search the web for [selection] (already implemented in bug 15176)
- look up selection in a dictionary
- look up selection in an encyclopedia
- look up information about selected company name

- highlight (change background color of selection)
(Reporter)

Updated

17 years ago
Blocks: 10080

Updated

17 years ago
Depends on: 75338

Comment 1

17 years ago
it's not as if there's zero cost in adding this, as novice users may not need or
want to distinguish between contextual clicking on a highlighted areas vs.
unhighlighted areas.  This adds one more layer of sophistication to contexutal
features.  i think any selection features should only be produced in a menu when
and if a user is clicking over the selected area, otherwise he/she gets the
previous available context.  in other words if a user has selected text, but
hasn't right clicked directly on it, he/she gets normal page/frame context menu.

alternatively we could add a new subset of contextual menu items underneath the
preceded context. so that the menu expands coherently as new contexts are revealed.
(Reporter)

Comment 2

17 years ago
I think the best would be to show a normal context menu if the user doesn't 
click on the selection.  It's too easy to create a selection and then forget 
about it.

Comment 3

17 years ago
i agree. it's also very easy to just accidentally select text. even worse, then
scroll it out of view, and you wouldn't understand why you weren't getting a
normal context menu.  

highlight and context-click directly over the selection is the most intentional
way to call up the menu. the menu should be a subset of the normal context menu,
with a new selection based set underneath.
(Reporter)

Comment 4

17 years ago
What items from the normal context menu should be included?  I can only think 
of "copy", but that shouldn't be on the non-selection context menu because it 
is always disabled.

Comment 5

17 years ago
Oops, just filed dupe bug 107662 > Browse to "selected text" context menu item.

Comment 6

17 years ago
*** Bug 107662 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
->marlon, cc mpt, for possible inclusion in spec
Assignee: pchen → marlon

Updated

17 years ago
No longer depends on: 75338

Updated

17 years ago
Blocks: 75338

Updated

17 years ago
No longer blocks: 75338

Updated

17 years ago
Depends on: 75338
(Reporter)

Updated

17 years ago
Blocks: 9274
Depends on: 131542

Comment 8

17 years ago
--- these are good ideas. some of them have been included in my spec revision
for context menus. however, some requests such as 'selected as URL or email'
offer marginal utility, and don't quite deserve a spot in this context menu,
relative to the items that do. "Look up selection in Encylopedia" would be
entertaining, but not quite as useful as dictionary for example...

i have posted the 2nd draft to the Context Menu Revision 2 document located:

http://mozilla.org/projects/ui/communicator/framework/contextmenus/cmrev2-2.html
It could have a "Translate selection" option... is there a bug for this?

Updated

17 years ago
No longer depends on: 75338
(Reporter)

Updated

17 years ago
No longer depends on: 131542

Comment 10

17 years ago
This needs to be turned into a meta bug or closed, it's not useful in its
current state.
(Reporter)

Updated

17 years ago
Depends on: 135225
(Reporter)

Comment 11

17 years ago
Copy
Highlight
----
Search Web for "foo"
Look Up in Dictionary
----
Open 3 Links in Windows (bug 9274)    \
Open 3 Links in Tabs                  | disabled if no links selected
Copy Link Addresses                   /
----
View Selection
View Selection Source (bug 49721) (may not be necessary if View Selection
followed by View Source works correctly)
also, from marlon's spec: "Send Quoted Selection".
(Reporter)

Updated

16 years ago
Depends on: 122524, 139005

Updated

16 years ago
Depends on: 146888

Comment 13

16 years ago
RFE: I would like to see 'View Page Source' in the context menu for images,
since with current design trends in HTML pages, it's sometimes hard
to see/find a spot where there is no (background) image :-)
(Reporter)

Updated

16 years ago
Depends on: 169718
(Reporter)

Updated

16 years ago
Depends on: 166317

Comment 14

15 years ago
The one I would use daily is Print Selection.
Product: Core → Mozilla Application Suite

Comment 15

12 years ago
@comment #0: 
my votes, for what might be useful:

    1) copy
    2) copy as text (eg to paste into MS Word) (bug 67142)

(+) 3) treat selected text as a link or e-mail address (bug 10080)
(+) 4) open [number] selected links in new windows (bug 9274)

    5) view partial source (bug 49721)
(+) 6) open selection as a new document (eg to print, save, or use a bookmarklet)
(if this is possible at all?!)

    7) search the web for [selection] (already implemented in bug 15176)
-   8) look up selection in a dictionary
-   9) look up selection in an encyclopedia
-  10) look up information about selected company name

-  11) highlight (change background color of selection)


What i would like especially is:

4b) mark some text on the webpage and DO something with all marked links (this is similar to 4));
for example: download the link targets (this is Bug 245344 (closed))

Comment 16

11 years ago

I wanted to link to Bug 350867 here, to add "Copy as HTML" to the selection contextual menu.


Also, some of this stuff can be done with extensions.  For example there's an extension that converts a selected time to different timezones, really useful.
(Reporter)

Updated

11 years ago
Depends on: 350867
Assignee: marlon.bishop → jag
QA Contact: bugzilla

Comment 17

9 years ago
Sorry, this bug mixes too many items. Please file individual bugs for individual things that should be in there.

That said, in my view, most of those wishes are nothing we will fix in main UI, but feel free to develop an add-on for SeaMonkey 2 that achieves this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 18

9 years ago
If individual bugs are created, please remember to come back to this one to report them, so the current watchers can also watch those.
You need to log in before you can comment on or make changes to this bug.