Closed Bug 1663209 Opened 1 year ago Closed 1 year ago

intermittent comm/mail/test/browser/tabmail/browser_dragndrop.js | Uncaught exception - at resource://testing-common/mozmill/utils.jsm:127 - TimeoutError: Timed out waiting for message display completion.

Categories

(Thunderbird :: General, defect, P5)

defect

Tracking

(thunderbird_esr78 unaffected, thunderbird82 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird82 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mkmelin)

References

Details

(Keywords: intermittent-failure, leave-open)

Attachments

(3 files)

Summary: perma comm/mail/test/browser/tabmail/browser_dragndrop.js | Uncaught exception - at resource://testing-common/mozmill/utils.jsm:127 - TimeoutError: Timed out waiting for message display completion. → intermittent comm/mail/test/browser/tabmail/browser_dragndrop.js | Uncaught exception - at resource://testing-common/mozmill/utils.jsm:127 - TimeoutError: Timed out waiting for message display completion.

This seems to make it pretty solid.

Sent to try now https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=70b65383df399e43e9df6f2c0e7ae311eccc0eec

For the assert_selected_and_displayed, I don't know how that ever works without passing the controller. Looks like it did the wrong checks and passed accidentally.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9175172 - Flags: review?(geoff)

Comment on attachment 9175172 [details] [diff] [review]
bug1663209_test_dnd_failure.patch

The controller is assumed to be mc if not passed, but that's not obvious it's so better to be explicit.

Attachment #9175172 - Flags: review?(geoff) → review+

The test failed on Mac and Windows on your Try run. I'm not sure if this is related to the other noise or not, so probably best to try Try again.

https://phabricator.services.mozilla.com/D90253 to avoid the tree.view.selection null problems

Likely happens mostly in automation. At least Thunderbird have places where the view is going to be replaced and the selection is cleared first.

Attachment #9175790 - Attachment description: Bug 1663209 - currentIndex should return -1 when tree.view.selection is null. r=ntim → Bug 1663209 - currentIndex should return -1 when tree.view.selection is null. r=ntim, Gijs
Attachment #9175790 - Attachment description: Bug 1663209 - currentIndex should return -1 when tree.view.selection is null. r=ntim, Gijs → Bug 1663209 - currentIndex should return -1 when tree.view.selection is null. r=ntim
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d4122bf21071
currentIndex should return -1 when tree.view.selection is null. r=ntim
Keywords: leave-open
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/7019fe66b32b
Use Services.tm.dispatchToMainThread instead of setTimeout when opening a new window. r=mkmelin
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Comment on attachment 9176816 [details]
Bug 1663209 - Use Services.tm.dispatchToMainThread instead of setTimeout when opening a new window. r?mkmelin

[Approval Request Comment]
Just a test perma-failure fix.

Attachment #9176816 - Flags: approval-comm-beta?

Comment on attachment 9176816 [details]
Bug 1663209 - Use Services.tm.dispatchToMainThread instead of setTimeout when opening a new window. r?mkmelin

[Triage Comment]
Approved by wsmwk via Matrix for 82.0b1

Attachment #9176816 - Flags: approval-comm-beta? → approval-comm-beta+
Regressions: 1689724
You need to log in before you can comment on or make changes to this bug.