Closed Bug 1663317 Opened 2 years ago Closed 2 years ago

Unreadable title bar + parts of screen no longer rendered

Categories

(Core :: Widget: Gtk, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1663279
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 + fixed

People

(Reporter: gcp, Assigned: stransky)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image linuxregress.png

Ubuntu 18.04, Nightly, nvidia 450.51.06 drivers, GTX 1060

mozregression is broken so I can't bisect, but it's at least: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aa032cbc94551a0f6e7e821d78aa0388f998e830&tochange=0e6484c306af81dffef0987332ff114ec6263b00

So bug 1460959 and related changes look suspicious.

See screenshot - the browser is unusable.

Severity: -- → S1

Yes, that seems to be related. Is that basic compositor or WebRender? If WebRender, can you try Basic?
Thanks.

Assignee: nobody → stransky
Blocks: gtktitlebar
Flags: needinfo?(gpascutto)
Priority: -- → P1

Also I expect you use KDE, right?

Regressed by: 1460959

This is WebRender + KDE indeed.

Flags: needinfo?(gpascutto)

Needinfo to check with Basic when I get back to the Linux system.

Flags: needinfo?(gpascutto)

Basic or OpenGL compositor fixes the graphical glitches, but the tab names/titles are still unreadable.

Flags: needinfo?(gpascutto)

Actually, even with Basic compositor (and OpenGL too), the bottom part of the window isn't rendered but transparent. Took me a minute to notice because the underlying window had the same color :)

So, after playing with it more, I think the problem is a) The borders are no longer rendered correctly b) The sizing of the window is off - the desktop seems to be confused about how big the Firefox window should be. It's leaving room for a huge border underneath.

Attached image linuxregress2.png

Screenshot of how it looks with Basic compositor.

Can you please test latest nightly with Bug 1663279 fixed?
Also is the titlebar hidden by default for you?
Thanks.

Flags: needinfo?(gpascutto)

The titlebar is visible by default for me.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gpascutto)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.