Closed Bug 1663279 Opened 2 years ago Closed 2 years ago

Titlebar setup misconfiguration

Categories

(Core :: Widget: Gtk, defect, P2)

Firefox 82
Desktop
Linux
defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- fixed

People

(Reporter: mathew.hodson, Assigned: stransky)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Bug 1460959 now hides the title bar by default in more environments, but the new code ignores the level of support defined in GetSystemCSDSupportLevel().

The if statement should be added back in HideTitlebarByDefault() at https://searchfox.org/mozilla-central/rev/dc30fc92f2d02abe716426df7eff0f0bbb907da2/widget/gtk/nsWindow.cpp#7848

if (hideTitlebar) {
  GdkScreen* screen;
  hideTitlebar = ((screen = gdk_screen_get_default()) &&
                  gdk_screen_is_composited(screen)) ||
                 TitlebarCanUseShapeMask();
}
Regressed by: 1460959
Has Regression Range: --- → yes

You should be able to test by setting env MOZ_GTK_TITLEBAR_DECORATION to none.

Expected:
Title bar is hidden by default.

Actual:
Title bar is shown by default.

OS: Unspecified → Linux
Hardware: Unspecified → Desktop
Version: unspecified → Firefox 82

Ahh, you're right! Thanks a lot.

Assignee: nobody → stransky
Blocks: gtktitlebar
Attachment #9174095 - Attachment is obsolete: true
Summary: HideTitlebarByDefault() ignores GetSystemCSDSupportLevel() → Titlebar setup misconfiguration
Priority: -- → P2
  • Use toplevel transparent window by default.
  • Use Client decoration for Deepin desktop.
  • Hide system titlebar by default on latest KDE versions.
  • Hide system titlebar by default on Gnome/Pantheon.
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c500459f5539
[Linux] Update default titlebar configration, r=jhorak
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Duplicate of this bug: 1663317
Duplicate of this bug: 1663206
Blocks: 1663194
Regressions: 1677241
You need to log in before you can comment on or make changes to this bug.