Closed Bug 1663321 Opened 1 year ago Closed 11 months ago

New Chat Contact doesn't work through menu or AppMenu

Categories

(Thunderbird :: Instant Messaging, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird83 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird83 --- fixed

People

(Reporter: Paenglab, Assigned: khushil324)

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

When I try to add a new Chat account through menu File/New/Chat Contact... or through AppMenu I get following error:
Uncaught Error: No connected account! addbuddy.js:24:13
onload chrome://messenger/content/chat/addbuddy.js:24
onload chrome://messenger/content/chat/addbuddy.xhtml:1
_openDialog chrome://messenger/content/chat/chat-messenger.js:1051
addBuddy chrome://messenger/content/chat/chat-messenger.js:1058
doCommand chrome://messenger/content/mail3PaneWindowCommands.js:1123
doCommand chrome://messenger/content/mailTabs.js:844
doCommand chrome://messenger/content/tabmail.js:577
goDoCommand chrome://global/content/globalOverlay.js:101
oncommand chrome://messenger/content/messenger.xhtml:1

Through Chat tab "Show Accounts" button and then "New Account" in the dialog works.

Id do get stuff in the error console (per below), but it still works for me on trunk.

TypeError: can't access property "windowGlobalChild", window is undefined
getWindowID resource://devtools/server/actors/targets/browsing-context.js:75
onWindowCreated resource://devtools/server/actors/targets/browsing-context.js:1765
makeInfallible resource://devtools/shared/ThreadSafeDevToolsUtils.js:103
_fireEvent chrome://global/content/elements/wizard.js:484
set currentPage chrome://global/content/elements/wizard.js:197
advance chrome://global/content/elements/wizard.js:326
_maybeStartWizard chrome://global/content/elements/wizard.js:422
_registerPage chrome://global/content/elements/wizard.js:401
connectedCallback chrome://global/content/elements/wizard.js:500
openIMAccountWizard chrome://messenger/content/mailCore.js:648
oncommand chrome://messenger/content/messenger.xhtml:1
ThreadSafeDevToolsUtils.js:82:13
reportException resource://devtools/shared/ThreadSafeDevToolsUtils.js:82
makeInfallible resource://devtools/shared/ThreadSafeDevToolsUtils.js:109
_fireEvent chrome://global/content/elements/wizard.js:484
set currentPage chrome://global/content/elements/wizard.js:197
advance chrome://global/content/elements/wizard.js:326
_maybeStartWizard chrome://global/content/elements/wizard.js:422
_registerPage chrome://global/content/elements/wizard.js:401
connectedCallback chrome://global/content/elements/wizard.js:500
openIMAccountWizard chrome://messenger/content/mailCore.js:648
oncommand chrome://messenger/content/messenger.xhtml:1

Assignee: nobody → khushil324
Attachment #9183741 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Attachment #9183741 - Flags: review?(mkmelin+mozilla) → review?(richard.marti)

Comment on attachment 9183741 [details] [diff] [review]
Bug-1663321_fix-new-chat-contact-menu-0.patch

With no chat connected there is no menuitem. Better is show it but disabled. Like this the user knows there is a menuitem for it.

When connected, the menuitem is there and I can create a contact through the main menu. But when I try through the AppMenu the item is disabled and after this the item in the main menu too. I found no way to enable it again. Only a restart of TB and connecting again the chat makes the main menuiten active again.

Attachment #9183741 - Flags: review?(richard.marti)

menuitem.disabled is not working actually, that's why I tried the hidden thing. Any idea how to solve this problem? I was facing a similar problem in any previous bug also.

It's a bigger problem actually, Join Chat and Chat Status Menu items are also not working properly. I will include the fixes in the patch.

Attachment #9183741 - Attachment is obsolete: true
Attachment #9183974 - Flags: review?(richard.marti)

Comment on attachment 9183974 [details] [diff] [review]
Bug-1663321_fix-new-chat-contact-menu-1.patch

Works and LGTM. Please update the reviewer in the commit message. And Maybe remove the "Fix" in it.

Attachment #9183974 - Flags: review?(richard.marti) → review+
Attachment #9183974 - Attachment is obsolete: true

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fc4e09c862e4
Fix Chat menuitems in Main menu and AppMenu. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Is 78 affected as well? Please set the flag if it is.

Target Milestone: --- → 84 Branch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9184026 - Attachment is obsolete: true
Attachment #9184162 - Flags: review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/28242e5cc885
Fix Chat menuitems in Main menu and AppMenu. r=Paenglab DONTBUILD

Status: REOPENED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED

Comment on attachment 9184162 [details] [diff] [review]
Bug-1663321_fix-new-chat-contact-menu-3.patch

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Chat Menu Items in the menubar and AppMenu are not working correctly.
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky): Low

Attachment #9184162 - Flags: approval-comm-esr78?
Attachment #9184162 - Flags: approval-comm-beta?

Comment on attachment 9184162 [details] [diff] [review]
Bug-1663321_fix-new-chat-contact-menu-3.patch

[Triage Comment]
Approved for beta

Attachment #9184162 - Flags: approval-comm-beta? → approval-comm-beta+

Successfully created a chat account using File > New > Chat Account from the File Menu in my test of 83.0b3 on Windows 10.

Sorry, I didn't find this in previous testing as I was using the Account Hub buttons.

Comment on attachment 9184162 [details] [diff] [review]
Bug-1663321_fix-new-chat-contact-menu-3.patch

[Triage Comment]
Approved for esr78

Attachment #9184162 - Flags: approval-comm-esr78? → approval-comm-esr78+

Created Chat accounts from the Menu and App Menu.
Created Chat oontacts from the Menu and App Menu once the accounts were connected in my test of the 78.5.0 release candidate on Windows 10 (20H2).

You need to log in before you can comment on or make changes to this bug.