If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

next unread news does nothing if all messages are read and a new one arrives

RESOLVED FIXED

Status

MailNews Core
Backend
--
minor
RESOLVED FIXED
15 years ago
7 years ago

People

(Reporter: hana.skoumalova, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020902
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020902

If I read all messages in a newsgroup and leave focus on that newsgroup I can't
read new messages which arrive later by pressing 'N'. I have to move focus to
anothe group or to a mail folder. After pressing 'N' I get the dialog box about
moving to the newsgroup with a new message.

Reproducible: Always

Steps to Reproduce:
1. Read all new messages.
2. Leave focus on the newsgroup.
3. Wait for some new messages in that newsgroup (the newsgroup name gets bold
and a number of new messages is displayed).
4. Hit 'N'

Actual Results:  
Nothing.

Expected Results:  
Move focus to the next unread message and display it.

There is an easy workaround - I move focus on another newsgroup and then 'N'
works as expected, but it is several more hand-moves.

I am using the modern theme. 

This bug is quite old, but there were more annoying ones and that's why I'm
reporting it only now.
Same over here using Mozilla release 1.1 for Linux.

Updated

15 years ago
QA Contact: olgam → laurel

Comment 2

15 years ago
Me too, would like to get this solved.

NT & Mozilla 1.2a

Comment 3

15 years ago
*** Bug 177473 has been marked as a duplicate of this bug. ***
Please can the owner of this bug or anybody else who is allowed to set Hardware
and OS to all (see commect #2 and comment #3)?
Maybe this helps to get some attention on this.
(Reporter)

Updated

13 years ago
OS: Solaris → All
Hardware: Sun → All
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 5

11 years ago
It is still here in Thunderbird 2.0.
Assignee: mail → nobody
QA Contact: laurel → message-display
next fails for both SM and TB. I did not check for dupes.

I set check for messages every 1 minutes. Post new message, after x minutes  unread count goes up when message detected, but thread pane doesn't get the new message(s).
Component: MailNews: Message Display → Backend
Product: SeaMonkey → MailNews Core
QA Contact: message-display → backend
Summary: next unread does nothing if all messages are read and a new one arrives → next unread news does nothing if all messages are read and a new one arrives
Version: Trunk → unspecified
This still happens with Thunderbird 3.0 Beta 4.
This should be fixed by bug 311774 under rc1 (I didn't get the fix in time for b4...).
Thanks, will test this when rc1 is released.
This works with Thunderbird 3.1.4.

Comment 11

7 years ago
Yes, this was really fixed somewhere around 3.1 (and definitely works in 3.1.4)

I think status should be set to RESOLVED FIXED.
Per comments 8, 10, and 11, this was fixed by bug 311774.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 311774
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.