Closed Bug 1664442 Opened 2 years ago Closed 2 years ago

Screen turns white on pinch-zoom when slowly scrolling the page

Categories

(Core :: Panning and Zooming, defect, P3)

All
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox82 --- affected

People

(Reporter: simona.marcu, Assigned: kats)

References

Details

Attachments

(1 file, 1 obsolete file)

Affected versions
Firefox Nightly 82.0a1

Affected platforms
Mac OS X 10.15

Preconditions
gfx.webrender.all = true or gfx.webrender.all = false
apz.allow_zooming = true

Steps to reproduce

  1. Navigate to https://edition.cnn.com/ and read an article
  2. Pinch zoom to the maximum
  3. Slowly scroll the page using the touchpad (up/down, right/left)
  4. Wait for a little after each scroll

Expected result
Pages should be correctly displayed while pinch-zooming and scrolling.

Actual Result
Pages turn white while scrolling. Please see the screencast for more details.
https://drive.google.com/file/d/17v0wtKy-W7i578Oj-tB7WH8OfSaON82D/view?usp=sharing

Blocks: desktop-zoom-release
No longer blocks: desktop-zoom-post
Severity: -- → S3
Priority: -- → P3

Are you still able to reproduce this? If so, after reproducing the problem, can you go to about:checkerboard, select the matching report (if there is one), copy the "raw log" at the bottom, and attach it to this bug?

Flags: needinfo?(simona.marcu)
Attached file rawLog.doc (obsolete) —

Yes, I can still reproduce this issue - reproduced it using the latest Nightly 83.0a1 on a Mac OS X 10.15 - on a MacBook Pro (Retina, 15-inch, Late 2013) - 2.6 GHz Quad-Core Intel Core i7. I'm attaching the "raw log" for this.

I also tried to reproduce this issue on a MacBook Pro (16-inch, 2019) - 2,3 GHz 8-Core Intel Core i9, but I couldn't.

Flags: needinfo?(simona.marcu)
Attached file rawLog as plaintext
Attachment #9180678 - Attachment is obsolete: true

This log seems to be of a checkerboarding event while zooming out, which doesn't match the STR from comment 0. It's possible that the STR in comment 0 are generating a visual effect like checkerboarding via some other mechanism.

While zooming in and out on ebay.com I still see some glitching that results in checkerboarding. I'm not sure of the root cause but looking at the produced about:checkerboard logs it certainly seems like the requested displayport is doing strange things. That might be related to this bug. I'll try and dig into it a bit more.

Assignee: nobody → kats

Are you still able to reproduce this on the latest nightly? The fixes from bug 1654290 and bug 1671284 may have resolved this issue as well. I'm still not able to reproduce and I can barely even reproduce the glitching I was seeing pretty consistently before.

Flags: needinfo?(simona.marcu)

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)

Are you still able to reproduce this on the latest nightly? The fixes from bug 1654290 and bug 1671284 may have resolved this issue as well. I'm still not able to reproduce and I can barely even reproduce the glitching I was seeing pretty consistently before.

I can't reproduce it either, tested on the latest Nightly 84.0a1 (2020-10-21), and Mac OS X 10.15.

Flags: needinfo?(simona.marcu)

Great, thanks! I'll close this bug, assuming it was fixed by one of the other fixes.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.