Closed Bug 1620056 (desktop-zoom-release) Opened 9 months ago Closed 1 month ago

[meta] Let desktop zooming ride the trains

Categories

(Core :: Panning and Zooming, task, P3)

task

Tracking

()

RESOLVED FIXED
Tracking Status
relnote-firefox --- 83+
firefox75 --- wontfix

People

(Reporter: botond, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: dev-doc-needed, meta)

This bug tracks issues blocking desktop zooming riding the trains to the release channel.

Depends on: 1631015
Depends on: 1632357
Depends on: 1556962
Depends on: 1640347
Depends on: 1642447
Depends on: 1642340
Depends on: 1642308
Depends on: 1642494
Depends on: 1642495
Depends on: 1642526
Depends on: 1643097
Depends on: 1643461
Depends on: 1643508
Depends on: 1641300
Depends on: 1644952
No longer depends on: 1644952
Depends on: 1645433
Depends on: 1518908
Depends on: 1623473
Depends on: 1619186
Depends on: 1648641
Depends on: 1648686
Depends on: 1648491
Depends on: 1648425
Depends on: 1651149
Depends on: 1653576
No longer depends on: 1653576
Blocks: 1654011
Depends on: 1647546
No longer depends on: 1642340
Depends on: 1654290
Depends on: 1655167
Depends on: 1656802
No longer depends on: 1534459
No longer depends on: 1642495
No longer depends on: 1518908
No longer depends on: 1554795
No longer depends on: 1610657
No longer depends on: 1623473
No longer depends on: 1631015
No longer depends on: 1642494
No longer depends on: 1645433
No longer depends on: 1648427
Depends on: 1657822
Depends on: 1525259
Depends on: 1658522
Depends on: 1658647
No longer depends on: visual-viewport-api-desktop
No longer depends on: 1648425
Depends on: 1659707
Depends on: 1660246
Depends on: 1660431
Depends on: 1645433
No longer depends on: 1525259
No longer depends on: 1641300
No longer depends on: 1660054
No longer depends on: 1660431
No longer depends on: 1645433
Depends on: 1663646
No longer depends on: 1658522
Depends on: 1669797
Depends on: 1669952
Depends on: 1669982
Depends on: 1670704
Depends on: 1670877
Depends on: 1671235
No longer depends on: 1670704

It's riding the trains on Fx83, so let's close this bug.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Release Note Request (optional, but appreciated)
[Why is this notable]: New user-facing interaction feature
[Affects Firefox for Android]: No
[Suggested wording]: Users with touchscreens and precision trackpads can now use pinch gestures on those devices to zoom web content without reflowing
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?

ni?pascal to make sure the relnote-firefox flag does not get overlooked before the 83 release.

Flags: needinfo?(pascalc)
Duplicate of this bug: desktop-zoom-win

Looks like this is part of the 83 release notes:
"Pinch zooming will now be supported for our users with Windows touchscreen devices and touchpads on Mac devices. Firefox users may now use pinch to zoom on touch-capable devices to zoom in and out of webpages."

Flags: needinfo?(pascalc)
You need to log in before you can comment on or make changes to this bug.