Closed Bug 1664534 Opened 2 years ago Closed 2 years ago

ThreadSanitizer: data race [@ EchoSubtraction] vs. [@ webrtc::WebRtcAec_CreateAec]

Categories

(Core :: WebRTC: Audio/Video, defect)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1657739
Tracking Status
firefox82 --- affected

People

(Reporter: decoder, Unassigned)

References

(Blocks 1 open bug)

Details

Crash Data

Attachments

(1 file)

The attached crash information was detected while running CI tests with ThreadSanitizer on try (parent revision is mozilla-central dc90a7a18c07).

For detailed crash information, see attachment.

Very quick analysis: It looks like we are racing the (re?)initialization of the webrtc::WebRtcAec_FilterFar global function pointer vs. calling that function. If the variable wasn't initialized by us previously, this should lead to a null crash.

General information about TSan reports

Why fix races?

Data races are undefined behavior and can cause crashes as well as correctness issues. Compiler optimizations can cause racy code to have unpredictable and hard-to-reproduce behavior.

Rating

If you think this race can cause crashes or correctness issues, it would be great to rate the bug appropriately as P1/P2 and/or indicating this in the bug. This makes it a lot easier for us to assess the actual impact that these reports make and if they are helpful to you.

False Positives / Benign Races

Typically, races reported by TSan are not false positives [1], but it is possible that the race is benign. Even in this case it would be nice to come up with a fix if it is easily doable and does not regress performance. Every race that we cannot fix will have to remain on the suppression list and slows down the overall TSan performance. Also note that seemingly benign races can possibly be harmful (also depending on the compiler, optimizations and the architecture) [2][3].

[1] One major exception is the involvement of uninstrumented code from third-party libraries.
[2] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[3] How to miscompile programs with "benign" data races: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf

Suppressing unfixable races

If the bug cannot be fixed, then a runtime suppression needs to be added in mozglue/build/TsanOptions.cpp. The suppressions match on the full stack, so it should be picked such that it is unique to this particular race. The bug number of this bug should also be included so we have some documentation on why this suppression was added.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1657739
You need to log in before you can comment on or make changes to this bug.