Closed Bug 1665141 Opened 6 months ago Closed 5 months ago

Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_click.py TestClickNavigation.<test> | AssertionError: u'http://127.0.0.1:49999/clicks.html' == 'http://127.0.0.1:49999/clicks.html'

Categories

(Testing :: Marionette, defect, P5)

defect

Tracking

(firefox-esr78 unaffected, firefox82 fixed, firefox83 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- fixed
firefox83 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: assertion, intermittent-failure)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=315758730&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/AjQGuXzzT0ykGNWuRrtJPw/runs/0/artifacts/public/logs/live_backing.log


>[task 2020-09-15T15:31:19.282Z] 15:31:19    ERROR -  TEST-UNEXPECTED-FAIL | testing/marionette/harness/marionette_harness/tests/unit/test_click.py TestClickNavigation.test_click_link_page_load | AssertionError: u'http://127.0.0.1:49999/clicks.html' == 'http://127.0.0.1:49999/clicks.html'
[task 2020-09-15T15:31:19.282Z] 15:31:19     INFO -  Traceback (most recent call last):
[task 2020-09-15T15:31:19.282Z] 15:31:19     INFO -    File "Z:\task_1600183382\build\venv\lib\site-packages\marionette_harness\marionette_test\testcases.py", line 196, in run
[task 2020-09-15T15:31:19.282Z] 15:31:19     INFO -      testMethod()
[task 2020-09-15T15:31:19.282Z] 15:31:19     INFO -    File "Z:\task_1600183382\build\tests\marionette\tests\testing\marionette\harness\marionette_harness\tests\unit\test_click.py", line 391, in test_click_link_page_load
[task 2020-09-15T15:31:19.283Z] 15:31:19     INFO -      self.assertNotEqual(self.marionette.get_url(), self.test_page)
[task 2020-09-15T15:31:19.283Z] 15:31:19     INFO -  TEST-INFO took 835ms

*[task 2020-09-15T15:31:18.447Z] 15:31:18     INFO -  TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_click.py TestClickNavigation.test_click_link_page_load*```

The click doesn't seem to have triggered a navigation:

[task 2020-09-15T15:31:18.728Z] 15:31:18     INFO -  1600183878723	Marionette	DEBUG	208 -> [0,7,"WebDriver:ElementClick",{"id":"20549e77-b5bb-42ef-9c4e-37ee9b9f4722"}]
[task 2020-09-15T15:31:18.733Z] 15:31:18     INFO -  1600183878729	Marionette	TRACE	Using browsing context 20
[task 2020-09-15T15:31:18.979Z] 15:31:18     INFO -  1600183878977	Marionette	TRACE	Canceled page load listener because no navigation has been detected
[task 2020-09-15T15:31:18.979Z] 15:31:18     INFO -  1600183878977	Marionette	DEBUG	208 <- [1,7,null,{"value":null}]

So it looks similar to bug 1665022.

See Also: → 1665022

If no navigation has been triggered we should figure that out on bug 1394354.

Depends on: 1394354

This actually happens for various tests under this test class.

Summary: Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_click.py TestClickNavigation.test_click_link_page_load | AssertionError: u'http://127.0.0.1:49999/clicks.html' == 'http://127.0.0.1:49999/clicks.html' → Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_click.py TestClickNavigation.<test> | AssertionError: u'http://127.0.0.1:49999/clicks.html' == 'http://127.0.0.1:49999/clicks.html'
Duplicate of this bug: 1665487

No more failures since bug 1394354 has been fixed.

Assignee: nobody → hskupin
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.