Closed Bug 1665930 Opened 2 years ago Closed 1 year ago

Unable to change width of columns in Today Pane, Tasks view

Categories

(Calendar :: Calendar Frontend, defect)

Thunderbird 78
defect

Tracking

(thunderbird_esr78+ affected)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 + affected

People

(Reporter: brad, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(6 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

On a clean profile:

  • Add a calendar with tasks.
  • Go to Calendar window, View -> Today Pane -> Show Today Pane
  • View Tasks
  • Click on the "columns" selection pulldown (right edge of header row) and add the "Due in" column
  • Drag the "due in" column header to the left of the "title" header
  • hover over the boundary line in the column header between "due in" and "title".
  • drag the boundary line between the "due in" and "title", attempting to make that column narrower.

Actual results:

  • nothing happens. the column divider is not selectable or draggable.
  • In xulstore.json["chrome://messenger/content/messenger.xhtml"]["unifinder-todo-tree"["widths"] is "0 0 0 0 0 0 0 0 0 0 0 0" and it seems the UI can't change it.

Expected results:

  • When the mouse hovers over the column boundary, the cursor should change to the "adjust column width" cursor.
  • When clicking and dragging, the column width should be updated in the UI.
  • The new column widths should be preserved in xulstore.json (I think).
Keywords: regression
Summary: Unable to change width of columns in Today Pane, Tasks view [regression] → Unable to change width of columns in Today Pane, Tasks view
Status: UNCONFIRMED → NEW
Ever confirmed: true

I can confirm that it is not possible to change the width of the columns, just reorder them (with Thunderbird 78.2.2 on macOS).

Component: General → Calendar Frontend
Duplicate of this bug: 1669770

Hmm, we're talking about the main task tab right? I can change width of columns there but the dividers aren't very visible...

(In reply to Magnus Melin [:mkmelin] from comment #3)

Hmm, we're talking about the main task tab right? I can change width of columns there but the dividers aren't very visible...

No, as described in the original report, the broken UI is on the right-hand sidebar that is present when View->Today Pane->Show Today Pane is selected, and within the Today Pane, the Tasks (or "Events and Tasks") views are selected.

This is reproducible on Thunderbird 78.3.3 on MacOS.

This is the Tasks view in Today pane in Thunderbird 68.12.1 with optimal column width

This is a screen shot from Tasks view in Today pane in Thunderbird 78.6.0 without being able to change the column widths. So the left column is to small and unusable, while the right column consumes much space, useless und simply lost space.

Problem still exists in Thunderbird 78.6.0. Occurs with Thunderbird for Linux and Windows. Still no chance to change the column width in the Tasks view. The left column is simply too small, so you can't really read the text and the right column wastes a lot of space for nothing....

It is extremely annoying that Thunderbird (68.12.1) refers to the new version every time it is opened. But because of this bug I prefer refuse the update :(

Any chance to change the column widths manually in any configuration file as a quick workaround?

This bug occurs on all versions from Thunderbird 76 to the latest build of Daily.

mozregression-gui (Windows) says:

I'm so pleased [well, kinda sorta] to have just now found that many other users also have this annoying bug. Otoh, the fact that it was first reported 8 months ago but remains unsolved, is a bit disappointing. Fwiw:

  1. I cannot now recall exactly which TB version introduced this bug, but atm i am using 78.10.2-1 & it has existed continuously for numerous version updates.
  2. It exists in my Arch KDE boot & my SparkyLinux Cinnamon boot.
  3. The actual dedicated full-window Tasks tab itself continues to function correctly; all its columns remain able to be manually resized with the column-edge cursor-handle.
  4. The bug manifests only in the Today Pane's Task view columns.
  5. It occurs for me in both my normal & clean profiles.
  6. I've inspected TB's about:config in hope of finding a pertinent option to enable, but alas no.

I do hope a Dev will become available soon to address this.

This problem has existed since the introduction of the new UI, any version >= 70.

I'm still on 68.12.1 from 30th Sep 2020 (!), which was the latest Thunderbird version without that bug.

The problem has nothing to do with the operating system, Windows version or Linux distribution used - it is generally present in every (!) Thunderbird after version 68.x.

8 Months and 56 versions later (including all the betas) and this annoying bug still exists and no one is able to fix this simple detail? :(

I investigated the build where this bug started. It is as follows.
Last good:

  • Nightly: 76.0a1 (20200324092643)
  • Beta: 75.0b3 (20200330190334)

First bad:

  • Nightly: 76.0a1 (20200325104745)
  • Beta: 75.0b1 (20200407173003)

pushlog_url: https://hg.mozilla.org/comm-central/pushloghtml?fromchange=13584f9e025c50294e64b29482d941e6ac8207af&tochange=8ca637b203363896d542f8921f82a0afb8139d8e
Of the changes listed in this log, two changesets are related to calendar.

[1] Bug 1589005 - Let default 'Home' calendar be disabled on first run. r=darktrojan
author: Paul Morris <paul@thunderbird.net>
changeset 29059: fb7372b0b4f73436f03d02908dbc954e9a48bc77

[2] Bug 1624241 - Drop "Lightning/version" from Thunderbird user agent string. r=pmorris
author Geoff Lankow <geoff@darktrojan.net>
changeset 29055: 3d92830a28e6a8c3f90e53a96748d8bfffbc757c

I hope the above infomation will help resolve the bug.

(In reply to EarlgreyTea from comment #12)

First bad:

  • Beta: 75.0b1 (20200407173003)

The above was a mistake.
First bad:

  • Beta: 76.0b1 (20200407173003)

-moz-box-ordinal-group was messing it up.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED

(In reply to Magnus Melin [:mkmelin] from comment #14)

Created attachment 9223325 [details]
Bug 1665930 - Unable to change width of columns in Today Pane, Tasks view. r=darktrojan

-moz-box-ordinal-group was messing it up.

Hi @mkmelin. Oh wow, are you implying that you have found the specific root cause, & worked out the solution? Do we know yet which future TB update will incorporate this please?

I followed your link to https://phabricator.services.mozilla.com/D115875, saw calendar/base/content/calendar-task-tree.js, was going to download it, but then realised i can't see where to put it in my /opt/thunderbird_en-GB/.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d567f96cff1a
Unable to change width of columns in Today Pane, Tasks view. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

(In reply to Kadee from comment #15)
It's now fixed in daily (once the build finishes in an hour or so).
I guess we could uplift it to 78.12 after some beta testing.

Target Milestone: --- → 90 Branch

(In reply to Magnus Melin [:mkmelin] from comment #17)

(In reply to Kadee from comment #15)
It's now fixed in daily (once the build finishes in an hour or so).
I guess we could uplift it to 78.12 after some beta testing.

Sounds great, looking forward to it. Thank you.

(In reply to Magnus Melin [:mkmelin] from comment #17)

It's now fixed in daily (once the build finishes in an hour or so).

I've tried Daily 90.0a1 (20210528104440) but still can't change the width of the Task view columns in the Today pane.
Please reopen this bug.

Well it's certainly working for me.

In Today pane it doesn't work for me initially, no left-right arrow pointer. I need to move one column, then the left-right arrow pointer appears and I can change the width. After a restart of TB again not possible to change the width until I move one column.

The same on Linux and Windows.

(In reply to Richard Marti (:Paenglab) from comment #21)

In Today pane it doesn't work for me initially, no left-right arrow pointer. I need to move one column, then the left-right arrow pointer appears and I can change the width. After a restart of TB again not possible to change the width until I move one column.

I confirmed that the situation would be the same.

Flags: needinfo?(mkmelin+mozilla)

My /opt/thunderbird_en-GB just updated to 78.11.0, so i felt a bit excited... only to find this bug remains unfixed. What a disappointing update.

It's indeed not quite working.

Status: RESOLVED → REOPENED
Flags: needinfo?(mkmelin+mozilla)
Resolution: FIXED → ---

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d38740a62304
part2 - fix for being unable to change width of columns in Today Pane, Tasks view. r=darktrojan

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: 90 Branch → 91 Branch

Sorry Magnus, pls can you help me understand? Am i correct to interpret your recent posts to mean ALL of the following?

  1. The bug IS fixed.
  2. Users will not benefit from this fix until TB v91, even though our current/latest version is...
  3. ...only 78.11.0

If my understanding is correct, my obvious question is... WHY do we need to wait another THIRTEEN VERSIONS?

Correct.
The Thunderbird release cycle is a bit odd: we only release major releases ~ once a year. The next one is 91, in August, so soon.

Oh, ok, thank you.

Well, it's August, & my impatience finally overwhelmed me, so instead of waiting longer, i downloaded & installed thunderbird-91.0b6.tar.bz2 [into my /opt/ directory]. When i read https://www.thunderbird.net/en-US/thunderbird/91.0beta/releasenotes/?uri=/thunderbird/releasenotes/&locale=en-GB&version=91.0&channel=beta&os=Linux&buildid=20210802205227, i cannot see any reference to this Bug, which worried me a little. When i launched TB 91.0b6, initially the columns still would not let me drag to resize them. Happily, after doing the trick described earlier by Richard https://bugzilla.mozilla.org/show_bug.cgi?id=1665930#c21, i then could do the resizing... & better yet, unlike Richard's earlier experience, now after relaunching TB the columns do still let me resize them.

Finally! ;-)

Oh, nice one. I've just discovered that now in 91, at long last, the text fields in Events & Tasks are able to be formatted, ie, no longer am i stuck with only boring plain-text. Thank you Devs, this is a lovely surprise!

You need to log in before you can comment on or make changes to this bug.