Closed Bug 1665971 Opened 1 year ago Closed 1 year ago

Random record topsite doesn't generate "telemetry and attribution" ping after restart

Categories

(Firefox :: Top Sites, defect)

Desktop
Unspecified
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 - wontfix
firefox82 --- wontfix

People

(Reporter: aflorinescu, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Attached file user.js

[Tracking Requested - why for this release]:
Random topsite refuses to send telemetry and attribution after restart.

[Suggested Severity:]

S1/S2

[Description:]

Main-preview environment on Kinto staging. After multiple tests and edits, I ended up with a record that still reproduces bug 1664203.

The record has been multiple times edited with no issue, but when I ended up re-verifying the timestamp bug 1665757, I realized out of the 4 attribution enabled topsites, only this one would refuse to send telemetry events and attribution request.

This is especially weird since this is a simple standard engine: amazon.de, with nothing special, like a timestamp.

Adding user.js for ease of reproducing. (you need env. variable for non-nightly versions XPCSHELL_TEST_PROFILE_DIR=foo)

Note that verifying the RS pipeline in Firefox lists the right RS topsites synced.

[Environment:]

dao's nightly try build (82 Nightly + fixes):
ryan's RC2 trybuild (RC2+ fixes)

Windows 10
Ubuntu 20.04

[Steps:]
  1. Open a terminal for non-nightly versions.
  2. export XPCSHELL_TEST_PROFILE_DIR=foo
  3. Create a profile and add the attached user.js
  4. Open browser console, enable XHR.
  5. New tab and click on amazon.de, example.com, baidu.com and abc.com
  6. Restart.
  7. New tab and click on amazon.de, example.com, baidu.com and abc.com
[Actual Result:]
  1. 4 XHR requests to https://topsites.services.mozilla.com/cid/amzn_2020_a1
  2. 3 XHR request to https://topsites.services.mozilla.com/cid/amzn_2020_a1
    Clicking again the amazon.de tile will not generate any telemetry or attribution ping.
[Expected Result:]
  1. 4 XHR requests to https://topsites.services.mozilla.com/cid/amzn_2020_a1
  2. 4 XHR requests to https://topsites.services.mozilla.com/cid/amzn_2020_a1
    Clicking again the amazon.de tile will generate telemetry or attribution ping.

This is because your RS URLs didn't end with a slash and therefore don't match the URLs recorded in history. I think this is something we just need to handle carefully in the top sites collection rather than working around it in product.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

(In reply to Dão Gottwald [::dao] from comment #1)

This is because your RS URLs didn't end with a slash and therefore don't match the URLs recorded in history. I think this is something we just need to handle carefully in the top sites collection rather than working around it in product.

Indeed, thanks! Adding the / to the URL name fixed the telemetry/attribution problem.

You need to log in before you can comment on or make changes to this bug.