Closed Bug 1666347 Opened 1 year ago Closed 1 year ago

Misc cleanup after removal of psutil

Categories

(Firefox Build System :: General, task)

task

Tracking

(firefox85 fixed)

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: rstewart, Assigned: mhentges)

References

Details

Attachments

(1 file)

No description provided.

Most of the deletions here come from bug 1481612, the --with-windows-wheel option to mach vendor python, which according to that commit message "is very single-purpose: it's intended to let us vendor an unpacked
wheel for psutil on Windows". Since vendoring psutil is something we're no longer doing, we can safely just delete that added code.

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:rstewart, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(rstewart)

Blocked on bug 1668395.

Flags: needinfo?(rstewart)
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/19f707f5c097
Delete assorted dead code after removal of vendored `psutil` r=firefox-build-system-reviewers,mhentges
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1dd480fd638
Delete assorted dead code after removal of vendored `psutil` r=firefox-build-system-reviewers,mhentges
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ce536574e74
Delete assorted dead code after removal of vendored `psutil` r=firefox-build-system-reviewers,mhentges

other than Ricky's work in the docker file:
https://hg.mozilla.org/mozilla-central/log/tip/taskcluster/docker/recipes/ubuntu1804-test-system-setup.sh

I don't see any other changes since August. I am not sure who should look at this, I suspect the ubuntu 18 docker images are out of date or if they were rebuilt would fail.

I am not sure who is the owner of the linux docker image (cc'ing managers of various automation teams), it sounds like we need to investigate if the current image can be rebuilt and used successfully?

Flags: needinfo?(jmaher)

It's the good old "ubuntu images are not reproducible, and ubuntu has updated packages with side effects on our tests" again.

Assignee: rstewart → mhentges
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/18d9b3798b38
Delete assorted dead code after removal of vendored `psutil` r=firefox-build-system-reviewers,rstewart
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Flags: needinfo?(rstewart)
Regressions: 1680051
You need to log in before you can comment on or make changes to this bug.